Can't disable auto-login without deleting cookies


(Tanner Filip) #1

I added a Firefox Account to my SSO account, and it started refusing to sign me in with GitHub. Since auto-login was enabled, I had to delete the cookies for Auth0 (which probably isn’t something most people would know to do) to get back into anything. There should be a way to sign out or disable auto-login when this happens.


(Hidde de Vries) #2

Hi Tanner,

Agreed! We have the ‘Enable / Disable Auto-login’ screen that you can reach from SSO Dashboard (which is only useful it you can log in there). The screen can be manually triggered by adding action=autologin_settings to the URL of the login form. We are exploring more places to expose that screen.

Unfortunately there is no way for us to end auto-login when it is happening as your browser has likely already started the redirect when you see the screen.

Hope this helps,

Hidde


(Hidde de Vries) #3

We’ve made some changes that make sure the login form stays in browser history and disable autologin when you navigate back to it (with browser back button) or refresh the login page (as we basically don’t autologin if we already tried in last 10 mins).

These are now live, please let me know if you have any feedback on this.


(Akshay) #4

The browser back button works. But there is a “Go Back” button inside the error page under “Need Help?” clicking which will go back and do autologin (endlessly). In fact, that’s how I reached this topic.