Can't open links, in emails and/or pdf files, with Firefox Developer Edition

Hi all, I’m not sure that this is the best place for this topic so any suggestion is appreciated.

I’m having a issue:

I updated Debian from Stretch (9) to Buster (10) and after the update I can not open links in EMAILS and/or PDFs a directly in Firefox Developer Edition. When I click on the links nothing happens. If I select Firefox-ESR as preferred applocarion (that’s the version Debian ships with STABLE) it just works fine.

I tried creating the entry vía .desktop file in ~/.local/share/applications, and I have also tried with the automatic .desktop file creation automatically made by Firefox after asking to the user if wants to make him the default browser.

The point is that after many hours I ended up finding that only specifying Terminal=true (Launch in Terminal) in the .desktop file I can open external links. But with an annoying terminal opened every time.

Do anyone have any advice on how could I solve this?

Thank you.