Clone installation setup problem

development

(Johny) #1

I have been trying to setup the CV app locally, but I encountered following errors attached in screenshotcv-cannotload .
The yarn log shows following message:

'[BE]     at PromisePool.query (/home/mint/voice-web/node_modules/mysql2/promise.js:323:22)
[BE]     at Mysql.query (/home/mint/voice-web/server/src/lib/model/db/mysql.ts:83:35)
[BE]     at process.internalTickCallback (internal/process/next_tick.js:77:7)
[BE] /api/v1/user_client'

I setup fresh Ubuntu server & installed git, node, npm, yarn, mysql
cloned the CV repo.
created config.json to mention AWS credentials and S3 bucket details.
I created mysql voiceweb db & provided voicecommons user all privileges. (although not mentioned anywhere in contributing.md) If the db is absent the error says ‘unknown database’ if db is present it says
[Table voiceweb.user_clients’ doesn’t exist.]

Surely this is a database connection/permissions error. I also setup remote AWS RDS with successful mysql connection. But got same errors as shown above.

What /server/src/lib/model/db/mysql.ts file does? it has different user/pass values than /server/src/config-helper.ts suggested.
Is there something I missed?

I also tried docker & with many other variations in vm but no succuess.
How do you successfully setup the CV app? Do we have sample config.json file (and where to keep it?


(Johny) #2

I have been tried various setups but no success. Somehow I managed to ‘yarn install’ with OK message. but stuck at following message when yarn start.
[FE] (node:125) DeprecationWarning: Tapable.plugin is deprecated. Use new API on '.hooks' instead
Apparently this is the same message where app stucks when using docker setup too.

  1. Can anybody confirm that you could successfully setup/launch the app with current version of CV on github?
  2. I presume the config.json file is saved at top directory /config.json where /README.md is located. Correct?
  3. Does the file config.json should look like this?

config.json

     {
      PROD: false, // Set to true for staging and production.
      SERVER_PORT: 9000,
      DB_ROOT_USER: 'root', // For running schema migrations.
      DB_ROOT_PASS: 'root-password_or-blank',  //depending on 
      MYSQLUSER: 'voicecommons', // For normal DB interactions.
      MYSQLPASS: 'voicecommons',
      MYSQLDBNAME: 'voiceweb',
      MYSQLHOST: 'localhost',  //or remote hostname e.g. AWS RDS endpoint
      MYSQLPORT: 3306,
      BUCKET_NAME: 'voiceweb-specific-name',
      BUCKET_LOCATION: 'name.region.amazonaws.com',
      ENVIRONMENT: 'default',

      S3_CONFIG: {
        signatureVersion: 'v4',
        useDualstack: true,
      },
      AUTH0: {
    	    DOMAIN: 'https://315343322323.signin.aws.amazon.com/console',
    	        CLIENT_ID: 'AKIAV7ORUA',
    		    CLIENT_SECRET: '7fiOB0c2erte1J3pIbxaXGVAQwlopc',
    		      },

      IMPORT_SENTENCES: true,
    };

Thank you.


(Gregor) #3

Hey Johny,

as mentioned in our chats, sorry for the complications during setup and the app is indeed running on my machine (and I know of some others).

The DeprecationWarning also comes up on my machine and doesn’t stop the app from running. I still think the most likely issue is a database misconfiguration. Can you post the log of the full app start again?

RE your other questions:

  1. Correct
  2. that looks good :+1:

Hope we’ll figure it out soon!


(Johny) #4

Thanks for the reply.
When I tried earlier the log stuck at Deprecation Warning for a long time and SSH used to get disconnected.
I finally got FE built message today without getting disconnect. but still didn’t get the valid response from browser(could not connect -maybe it’s something to do with firewall & security group of AWS.)
But will try some more.
& post my findings with right approach.