CreateModel failed with error code 12288

I have downloaded deepspeech model from

https://github.com/mozilla/DeepSpeech/releases/download/v0.5.1/deepspeech-0.5.1-models.tar.gz
tar xvfz deepspeech-0.5.1-models.tar.gz

On checking the version of deepspeech downloaded; deepspeech - v0.6.0-alpha.5-0-g5fa6d23 ; tensorflow - v1.14.0-14-g1aad02a78e

On running the predict function i am getting an error- CreateModel failed with error code 12288.

Using the following parameters -
N_FEATURES = 25
N_CONTEXT = 9
BEAM_WIDTH = 500

Where am i going wrong?

1 Like

Welcome to the forums @adesara.amit :slightly_smiling_face:

I could be wrong (what you’ve written about what you’ve done isn’t totally clear to me) but it looks like you installed from master. You’d need to install from the checkpoint for the last full release (ie 0.5.1) if you want to use the pre-trained model (which only exists for 0.5.1 and before)

1 Like

Hey,

I am new to deepspeech hence the issues. followed the below process to install

a) pip install deepspeech
b) wget https://github.com/mozilla/DeepSpeech/releases/download/v0.5.1/deepspeech-0.5.1-models.tar.gz
tar xvfz deepspeech-0.5.1-models.tar.gz

Is it the right process? How do i install from checkpoint?

Thanks in advance

You need deepspeech 0.5.1 instead of 0.6.0-alphaxxx

Iam also facing the same issue…

@adesara.amit I would suggest you to check the 2 file path paramaters in the Model() Function.

When I updated the code from
ds = Model('deepspeech-0.5.1-models/output_graph.pbmm', N_FEATURES, N_CONTEXT, 'deepspeech-0.5.1-models/alphabet.txt', BEAM_WIDTH)

to
ds = Model('deepspeech-0.5.1-models/deepspeech-0.5.1-models/output_graph.pbmm', N_FEATURES, N_CONTEXT, 'deepspeech-0.5.1-models/deepspeech-0.5.1-models/alphabet.txt', BEAM_WIDTH)

It worked.

I am getting the same error–> RuntimeError : CreateModel failed with error 12288

I am using the version :
Tensorflow : v1.13.1-10-g3e0cc53
DeepSpeech : v0.5.1-0-g4b29b78

I am using this through a virtual environment. What am I doing wrong ?

You need to install the 0.5.1 version of deep speech if you use the 0.5.1 model.

Hey everyone! this is my version
TensorFlow: v1.14.0-21-ge77504ac6b
DeepSpeech: v0.6.1-0-g3df20fe

I does that
(deepspeech-venv) C:\Users\User\HOME\tmp\deepspeech-venv\Scripts\deepspeech-0.6.0-models> deepspeech --model models/output_graph.pbmm --audio my_audio_file.wav
and i getting this error:

Not found: NewReadOnlyMemoryRegionFromFile failed to Create/Open: models/output_graph.pbmm : ╤шёЄхьх эх єфрхЄё эрщЄш єърчрээ√щ яєЄ№.
; No such process
Traceback (most recent call last):
File “c:\python\python37_2\lib\runpy.py”, line 193, in run_module_as_main
main”, mod_spec)
File “c:\python\python37_2\lib\runpy.py”, line 85, in run_code
exec(code, run_globals)
File "C:\Python\Python37_2\Scripts\deepspeech.exe_main
.py", line 7, in
File “c:\python\python37_2\lib\site-packages\deepspeech\client.py”, line 113, in main
ds = Model(args.model, args.beam_width)
File "c:\python\python37_2\lib\site-packages\deepspeech_init
.py", line 42, in init
raise RuntimeError(“CreateModel failed with error code {}”.format(status))
RuntimeError: CreateModel failed with error code 12288

Please help!

Hello can you help me?