Date Time addon

Hi all

Is anybody experiencing the same as me with the date-time add-on. My date -time add-on has been grayed out on two Webthings I’m running. I guess the effect will be it will not turn on/off my devices at specific times. Can anyone shed any light on this. I’ve tried updating my two systems but it’s telling me I’m up to date. Thanks in advance👍

I had the same issue, but i didn’t have time to look at the log so if ypu can take a look at it

Hi, interesting others have had this issue. I’ve had a quick look and didn’t see anything, there again maybe I didn’t go back in the log far enough not knowing when it happened so maybe I will take another look over the next few days. If I do find anything I’ll post my findings here. But in the meantime if anybody beats me to it , it would be good to know what you find.:+1:

if you disable and enable it back, you should see in the latest log what happened

Hi, brilliant, that’s really helpful to know. Much appreciated. As soon as I have I’ll post here.

Hi all
I have now looked at the log and in my case there are at least 10 screens data for the date time addon which is trying or showing its doing something. Alas, my knowledge on WT is minute so I really don’t understand what’s going off. As I mentioned, I’ve two of these units. One I uninstalled and reinstalled and that’s not fixed it either. One thing which does suprise me is I thought ( and maybe they are) these are standalone units, ie not needing the web unless you need to connect to it , for example updates.
Anyhow if anybody can help I’d very much appreciate it. Thanks

I’ll try to take somr time this week to look at it

edit:

got this error from the log :

2022-11-13 00:01:49.699 INFO   : date-time-adapter: config.py:35 ERROR Strange config:searchReplaceComas() takes 2 positional arguments but 3 were given
2022-11-13 00:01:49.702 INFO   : date-time-adapter: Traceback (most recent call last):
2022-11-13 00:01:49.703 INFO   : date-time-adapter:   File "/home/pi/.webthings/addons/date-time-adapter/pkg/config.py", line 27, in load
2022-11-13 00:01:49.705 INFO   : date-time-adapter:     self.searchReplaceComas(self, config)  # Replace comma w dot
2022-11-13 00:01:49.707 INFO   : date-time-adapter: TypeError: searchReplaceComas() takes 2 positional arguments but 3 were given
2022-11-13 00:01:49.709 INFO   : date-time-adapter: EXECPTION
2022-11-13 00:01:49.711 INFO   : date-time-adapter: can only update value with string or number
2022-11-13 00:01:49.713 INFO   : date-time-adapter: ('can only update value with string or number',)
2022-11-13 00:01:49.737 INFO   : date-time-adapter: ['Traceback (most recent call last):\n', '  File "/home/pi/.webthings/addons/date-time-adapter/main.py", line 41, in <module>\n    _ADAPTER = DateTimeAdapter(verbose=_DEBUG)\n', '  File "/home/pi/.webthings/addons/date-time-adapter/pkg/date_adapter.py", line 24, in __init__\n    self.start_pairing(1)\n', '  File "/home/pi/.webthings/addons/date-time-adapter/pkg/date_adapter.py", line 42, in start_pairing\n    self._config))\n', '  File "/home/pi/.webthings/addons/date-time-adapter/pkg/date_device.py", line 76, in __init__\n    _config.horizon)\n', '  File "/home/pi/.webthings/addons/date-time-adapter/pkg/util.py", line 22, in __init__\n    self.next_sunrise = self.calc_sunrise()\n', '  File "/home/pi/.webthings/addons/date-time-adapter/pkg/util.py", line 125, in calc_sunrise\n    observer_today = self.get_observer()\n', '  File "/home/pi/.webthings/addons/date-time-adapter/pkg/util.py", line 106, in get_observer\n    observer_today.horizon = self.horizon\n', 'TypeError: can only update value with string or number\n']```

i’ll take a look at the repo, version 1.2.1 is outdated due to this bug :slight_smile:

at what i saw the current version is 1.2.3 who should fix issue, i saw the webthings pr have been accepted for the version 1.2.3, but the addon is still only visible at 1.2.1

not sure if it’s related to all the cert issue @benfrancis

Hi thanks that’s really decent of you. I’ve tried to copy some of what I see but at the moment it’s not having it. Not sure why it’s not letting me, anyhow if I crack it, I’ll put it on here. Thanks again for trying to help.

Absolutely brilliant, thanks Martin. I’ll see if I can get mine updated. Thing is I did delete and then reinstalled it so I’ll see what happens this time. Really grateful for your help. Thanks :+1:

If you want to fix it, yo can manually download version 1.2.3 and install it that should fix your issue(btw since the pi didn’t have Rtc(real time clock) it need internet to stay on the correct time)

I am in the middle of something and I’ll certainly give this a go in a bit. Thanks for the heads up on the manual installation ( I didn’t know you could do that) . Have to say, I’ve been using WT over a year and it’s been rock solid so I’ve not had chance to tweak or fix it. Just shows how good it is. I’m running my heating on it and it works just brilliantly. But Much appreciated for your help…thanks

Manual update instructions are at the end of this thread: Newbie question about missing addons

I just made the addon inactive. When i pressed update the addon disappeared. Then the only option was to install 1.2.3. all my settings was still there. Its working fine.

1 Like