EnableExternalScorer failed with 'Invalid scorer file.' (0x2002)

Hi,

We are using DeepSpeech to transcribe audio files that mostly pertain to medical lexicons. We tried adding a couple of words that were initially unavailable in the pre-built model and then created our own scorer file following the link : https://deepspeech.readthedocs.io/en/latest/Scorer.html#reproducing-our-external-scorer

The scorer file was generated, but on enabling the scorer, I get the below error which says the scorer file is invalid.

However, using deepspeech-0.9.3-models.scorer works fine except that domain-specific words are’nt recognized.

We tried reading multiple threads from this forum, however there were’nt sufficient information which could resolve our issue

All the steps followed are documented in https://docs.google.com/document/d/19ruyvTUFVn_goVINkO5GA8YjKpXrj2YKhkMoB5ooOfs/edit?usp=sharing

DeepSpeech model : 0.9.3
native_client : native_client.amd64.cpu.linux.tar.xz
Linux was used to build KenLM binaries and generate scorer : Ubuntu 20.04
Python version : 3.8.5

As in the guidlines, no images please.

Do you do everything on the same machine? Screenshots look like Windows to me. Test all with a really small scorer on one machine. And check how this message is thrown in the native client.

No external resources, please, share everything here as text only. It’s also super messy, you share infos about Ubuntu 20.04 but it’s all screenshots from Windows and obviously not over PuTTY.

We don’t support training on Windows, and we have no experience with WSL.

You also don’t share your code to repro: please verify your scorer works with our binaries, first. And why do we see ds.disableExternalScorer() followed by ds.enableExternalScorer() ?

KenLM is a git submodule, please use the same sha1 instead of downloading random version?