Error: Can't parse trie file, invalid header. Try updating your trie file

This is weird. TensorFlow sometimes messes up when you mix CPU and GPU packages (or release and nightly packages) in the same virtual environment. Could you try doing the following steps in a fresh virtualenv? It’s basically avoiding the first install of tensorflow since you want to install tensorflow-gpu. Also, you don’t need the deepspeech package for training.

pip3 install -r <(grep -v tensorflow requirements.txt)
pip3 install $(python3 util/ --decoder)
pip3 install tensorflow-gpu==1.14.0

Thx for the reply,
I will try this… :slight_smile:

Can we move that discussion to DeepSpeech problems with video card since it documents the very same issue ?

1 Like

I tried what @reuben said and I get the same error :confused:

I can’t reproduce your error. Did you change the code at all?

No, I did not change it

Nevermind, I made a mistake before, I can reproduce it now.

1 Like

I have identified the cause and am testing a fix. It’s a regression from commit dc78f8d1e65c4b387aa335df243898cd04704f98, which caused us to fallback on the default value for allow_soft_placement, which apparently is not True :slight_smile:


Thx for your help, I appreciate that
Can you please notify me when it’s fixed

I’ve made a PR here, waiting for tests results:

Can you test it and let me know if it works for you?

1 Like

it works perfectly … :wink:
Thx dude :slight_smile:

Thanks! PR merged. _