Firefox Add-ons Disabled Upon Start

So I have this extremely annoying issue. Almost every time I open Firefox on my system, all of my add-ons get disabled. There is no pattern to when it will happen either. Sometimes I can open it 2 or three time without a problem, other times its every single time, and to top it off all of my saved logins randomly disappear too. A simple closing and reopening of Firefox fixes that issue, but then my add-ons get disabled again.
I’ve tried making a new profile, didn’t work. Tired uninstalling Firefox and starting clean, still didn’t work. I’ve checked all my settings, and tried deleting the extensions data in the Mozilla folder. Nothing seams to work, and I don’t have a clue why this keeps happening. I’ve been using Firefox since it was still in beta, and have never had this kind of problem before.
Any advice would be greatly appreciated.

Operating System: Garuda Linux
KDE Plasma Version: 5.27.3
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 6.2.6-zen1-1-zen (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
Memory: 15.5 GiB of RAM
Graphics Processor: AMD Radeon RX 6700 XT
Manufacturer: Micro-Star International Co., Ltd.
Product Name: MS-7B79
System Version: 3.0

Firefox 111.0

Edit: I just noticed that some of my settings get reset to default as well. Namely my search bar settings.


This forum is not the right place to ask troubleshooting question. If you have a problem with Firefox that you need help with, please ask your question on the Firefox support forum instead. You can also see Get community support for other support resources - .

Thank you for pointing my in a more helpful direction. Though I don’t see why a discussion couldn’t be started on an interesting issue here.