Gateway on Synology Docker: Daemon already running

In the gateway log I see “Daemon already running on PID 14” repeating constantly every 1/2 second. Any ideas what’s causing this?
Apart from this everything seems to be Ok - I can scan sucessfully for zigbee devices and Onvif cameras.
P.S. on the Github page there are instructions for running the docker image from the command line, but it would be helpfull if it included instructions for running via the Docker GUI - it took me a lot of playing about to get it to work (e.g. had to use “high privilege” to get access to the USB port.

Update: I stopped and restarted the container and now I get: “Process 14 died: No such process; trying to remove PID file. (/run/avahi-daemon//pid)” repeating.

I was not aware that Docker provided a built-in GUI and have always used CLI commands for simple single cpu implementations (like Mozilla IOT). There are many 3rd-party GUI applications which are not authored by Docker and documentation how to use them should not be part of a Docker installation manual.

Here is the shell script I use to start a container for comparison.

docker run -d --device /dev/ttyACM0:/dev/ttyACM0 --restart always -v /path/to/shared/data:/home/node/.mozilla-iot --net=host --name mozilla-iot-gateway mozillaiot/gateway:latest

In the past, I’ve included the option: --restart always, that you may have used in your command line or select the option in your GUI, which is causing the repeated process died message due to an error. You may wish to disable restart for a time until you debug why the process is failing.

There are docker log commands to view the stdout of the contiainer which may contain helpful information about why the processes is dying.

@Geneva I merged in a fix for that issue this weekend. If you pull the latest image, it should be fixed.

Thanks. I pulled the latest image and now it works.
The only curious thing is that I have to use “high privilege” to give the container access to the USB port. My launch sequence is:
launch image
In create container tick ‘execute container using high privilege’
click advanced settings - tick ‘enable auto restart’
on network tab tick ‘use the same network as docker host’
on environment tab enter “–device /dev/ttyACM0:/dev/ttyACM0” in Command box
hit apply
hit next
hit apply.
If I launch without high privilege, the zigbee addon can’t access the usb port so It seems that putting “–device /dev/ttyACM0:/dev/ttyACM0” in the Command box has no effect.
Any ideas?

Can’t tell -f you have a single dash or double dash for you USB device option. Ubuntu docker cli command requires a double-dash for the “–device” option. Not sure if docker recognizes a single dash for command options.

I do not execute the container in privileged mode…

It’s double dash, but I guess I’m putting it in the wrong place. Maybe it should be in the folder tab. Or maybe I should just give up and use a cli command :grimacing: