How can I Debug/Profile sites in Firefox Preview Nightly?

Hi all,
I’m trying to profile Firefox Preview Nightly which I understand it’s possible. I failed.
I said to step back a little. Now I’m trying to debug Gecko View Example app using this tutorial:

My Firefox Nightly Does not see my USB phone.

What am I doing wrong?


Regardless of the application you want to debug, you should be able to see your phone in the sidebar of aboutdebugging as soon as the connection has been established. Normally the first time you connect to a new computer via USB, you should get a prompt on the phone to authorize the connection.

Did you get such a prompt when connecting the phone to the computer?

I don’t know which phone you are using but I wonder if the option “ADB over network” is compatible with the regular USB debugging. Can you try to toggle that off and unplug/replug to see if it helps?

1 Like

I tried it both on and off. I tried over network also.
I will revoke debug rights and see if I get the prompt again.

1 Like

Ok :confused: Note that if you want to connect via Network Location to this device (using the hostname:port displayed in the settings menu) you need to set devtools.debugger.force-local to false in about:config in your Desktop Browser (by default we only allow to connect to browsers running on the same machine)

(edit: the pref should be set to false, true is the default… old habits…)

1 Like

USB debugging seems to be ok on the phone. I removed the permission, I restarted the adb server

and this is what I see on my phone after accepting the remote device connection.

Still no luck over USB :frowning:

No clue what I did!!! IT WORKS NOW OVER USB!!!

Here is my first profile! UUUHUUUU

Thanks for digging into this and making it work, @andreip!

So it looks like running adb devices might have unstuck it?

1 Like

I think so. I tried a few other things like browser restart and revoking the debug rights of the laptop on the phone and adding it again but the adb server restart and devices might have fixed it.