How to create a mmap-able model from the output_graph.pb file

Yes that was the issue. Thanks.
Also I can use this mmap model.dorectly like how I use the regular model right ?? Or do I need to pass any new flags to achieve this ??


Just pass the different filename

Thanks alot for your help.

1 Like

Is that working properly now ? :slight_smile:

Hi @lissyx,

I did download the file you mentioned in this thread and it is in my current directory path. This is the command I am giving,

convert_graphdef_memmapped_format --in_graph=models/output_graph_trained_model_2.pb --out_graph=model/output_graph.pbmm

But I am getting,

convert_graphdef_memmapped_format: command not found

I also used,

./convert_graphdef_memmapped_format --in_graph=models/output_graph_trained_model_2.pb --out_graph=model/output_graph.pbmm

even here I am getting the same error.
where am I going wrong?

Thanks :slight_smile:

I really cannot help you for that, the error sugests that the binary is not here, but this is your system, I cannot do anything.

After download, you have to add executable permission for the file:
chmod +x convert_graphdef_memmapped_format

Then you can invoke the local command as:
./convert_graphdef_memmapped_format <your args>


How to use convert_graphdef_memmapped_format_lib.dms file in macOS ???

“convert_graphdef_memmapped_format.dms --in_graph=output_graph.pb --out_graph=output_graph.pbmm”

That’s the same as on any unix system, as explained above. I don’t know where you get convert_graphdef_memmapped_format_lib.dms from, it’s convert_graphdef_memmapped_format

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

@inforahul92 Well, I’m sorry, but this link is valid, and produces convert_graphdef_memmapped_format as expected. Now, if you are on macOS, then it’s not the proper link, and using util/ as documented should produce you this link

It might be possible that you have to rename to .gz and then gunzip before use.

No luck with this hack :frowning:

“no luck” is not really helpful: you report “issues”, refer to a filename that makes no sense, but you share no error at all. I don’t use macOS, I can’t help you if you don’t give more context.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

I just gave you the proper link above. It seems there’s a regression in the code and the url you report here is wrong. Hence 404.

1 Like

Issue resolved now,
The problem was with safari browser. Whenever I am opening your given URL “” in Safari it is downloading convert_graphdef_memmapped_format file in .dms format. Then I tried the same url into chrome browser and it is downloading convert_graphdef_memmapped_format file in the same format what I was expecting.

(deepspeech_env) Rahuls-MacBook-Pro-2:DeepSpeech-master rahulsharma$ ./convert_graphdef_memmapped_format --in_graph=/Users/rahulsharma/Documents/Tuple_Work/Speech/DeepSpeech-master/output_graph.pb --out_graph=/Users/rahulsharma/Documents/Tuple_Work/Speech/DeepSpeech-master/pbmm_file_generation/output_graph.pbmm

2019-06-14 22:23:45.413515: I tensorflow/contrib/util/] Converted 23 nodes

@lissyx Thank you so much for the help :slight_smile:

Weird. Could you file an issue for both problems? One for the invalid url and one for mentioning in the docs the safari’s behavior

1 Like

@lissyx I have raised below issue

How to download convert graphdef memmapped format binary file in safari broswer?

Well, I was more thinking about a Github issue …