I am unable to open some websites


(Tanushree 120692) #1

Unable to open some websites like www.chegg.com. It was working perfectly fine with previous versions of developer edition. I tried clearing cookies but didnot help. Please help!!


(Julien Tane) #2

A few questions:

  • do you get any specific errors in the Web Console?
  • did you also try it with another older version?
  • did you also try it with another profile?
  • which version did you use? to be sure: I could open the site with the 60.0b2 (64-bit) version…
  • what is not working can you describe it? usually bug descriptions are precise, concise and try to ease the reproduction, e.g:
  1. open web console
  2. navigate to the site

Expected Behaviour: the page loads and I can navigate to…
Current Behaviour: the page is only partially loaded …

Maybe the site: https://support.mozilla.org/en-US/ would be a better place?


(Tanushree 120692) #3

Hi,

The images are not loaded and the links are also not working. The feel and appearance has gone. This issue is only with Mozilla Developer version. It’s working fine with Mozilla Firefox, chrome.

Old versions of Mozilla Developer are not available for download.

I tried using different profile but facing same issue.

The login page is not working. www.chegg.com will open but if u click sign in/sign up it lands up to a page where nothing works. Images didn’t load and links are also not working.

I tried opening using version 60.0(b2). Tried uninstalling and installing, cleared cache and cookies but still not working.

Please help

Regards,
Tanushree


(Julien Tane) #4

Let me recapitulate,

  • you used different profiles , i.e no special extensions, standard properties
  • it does not work on for 60.0(b2) only
  • it works for me on 60.0b4 (64-bit) Linux
  • cookies and cache cleared ( the new profiles should do exactly the same thing…
  • which platform?
  • firewall? unlikely: proxy properties
    -are there any errors in the console

Here I got a few errors

c.cheggcdn.com:443 uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is unknown.
The server might not be sending the appropriate intermediate certificates.
An additional root certificate may need to be imported.

Error code: SEC_ERROR_UNKNOWN_ISSUER


failed to execute ‘postMessage’ on ‘DOMWindow’: The target origin provided (‘https://www.chegg.com’) does not match the recipient window’s origin (‘http://www.chegg.com’).

So I guess their certificate is not correct… this is why the resources are not displayed


(Tanushree 120692) #5

Hi Julius,

This website www.chegg.com is working fine with Chrome, Mozilla Firefox. The only issue is with Mozilla Developer edition. I am attaching a screenshot of the page I am getting. Also I’ll attach the screenshot of how it originally looks like. I am not getting any error only the look, feel and appearances have changed.

Regards,
Tanushree


(Julien Wajsberg) #6

Hi,

Everything looks as if the CSS isn’t loaded. Anything weird in the Web Console when you load the website?

It could be one of your extensions is doing bad things. Can you please try either with a new profile or with all extensions disabled? Here is how to do this:

  • creating new profiles: you can go to about:profiles to create profiles and load Firefox with a specific profile. Be careful to not use the same profile you use for stable firefox as it may lead to data loss!
  • restarting without any modules: you should have an entry in your help menu. There’s also a button in about:profiles.


Julien