I can't import my passwords from .csv file

Hello, Yesterday I had exported passwords as .csv and bookmarks.json before I Reinstalling Windows 10. Today I installed Mozilla Firefox again and now I want to import my passwords in new Firefox browser. But to my terrible surprise mozilla has not that function to “import from .csv”. and Also when I imported bookmarks.json All bookmark links where lost and only two empty folder added to mozilla bookmarks. I got too angry in real. What a hell is going on?

What can I do now?

that is a big FAIL. :cold_face:

we deserve better, even in windows.

Hmm, that’s puzzling because there’s a help article about it:


Try this to re-enable the missing menu item:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste import and pause while the list is filtered

(3) Double-click the signon.management.page.fileImport.enabled preference to switch the value from false to true

(4) Open the Logins and Passwords page or, if it’s already open, Reload it

This was a backup you made yourself from your old Firefox? Did you use the “Restore” function? That is the only one that can read JSON; the Import function only reads HTML.


You’ll need to use the “Choose File…” option and point Firefox to your backup file (any backup file already listed on the Restore menu is from the new installation).

Any luck?

1 Like

Thanks. I have imported saved passwords now but the passwords can’t be recovered because there is not any links in the .json file.
In conclusion, on that partly terrible disappointment form me I should take it easy.
Thanks again.

Hmm, I’m puzzled how you got a blank backup file. Was your Firefox having problems with history and bookmarks before your reinstall?

Do you have any other kind of backups from before the system reinstall?

Did you use one of the built-in methods of refreshing Windows that preserves your data in a


temporary folder?

I hadn’t problem with bookmarking but I was awkward by smart redirects.


I just reinstalled Win10
So I am keep calm. Happy new year, everybody :sunglasses:

It’s still a big fail in 2022 and even on MacOS. :man_facepalming:

Similar problem for me. Even after activating the menu option “import from .csv” with " signon.management.page.fileImport.enabled" = true , the menu option shows up, the dialog windows opens but Firefox simply fails to load the logins.

Chrome was able to import from the same .csv file so I don’t think it’s corrupted.

Same problem here.
On export, Firefox creates passwords.csv.
Attempting to import it to Firefox on a new Win10 system with the menu item “import from .csv” enabled does nothing.
Importing the passwords to Chrome succeeds; then “Import from Another Browser” (Chrome, in this case) succeeds in getting the passwords into FF.
Basically, this “workaround” requires installation of Chrome just to get your FF passwords from an old system to a new system’s FF.
From this thread, it looks like this has not been addressed for >2 yrs.

Type about:config in search bar
accept the fact you’re doing this at your own risk
security.allow_eval_in_parent_process to TRUE;
signon.management.page.fileImport.enabled to TRUE;
print(Have a good day!);
return 0;


This has been an on-going problem for me.
to true seemed to fix it, for some reason
was already set to true when I checked it.

I’m not sure why -and I don’t care since I am able to import my passwords.

In summary, what fixed my situation was:
signon.management.page.fileImport.enabled TRUE <<to allow importing
security.allow_eval_in_parent_process TRUE <<to coax firefox into actually reading the bloody CSV file.

After doing that, signon.management.page.fileImport.enabled had been set to true, but that may be a local (to me) thing and folks ought to probably check it anyway.

Thanks, @aevsolaev!


This worked for me! Thank you!

For me the import is now supported but I get an error now, saying a field was missing. From Chrome export I have the fields: name, url, username, password) Does anyone know, what the required fields for import in firefox are? How can I fix this?

Thank you so much for the help so far @rnd0

solved my problem thanks

I was pulling my hair out trying to figure this out. This worked for me. Thank you so much for sharing.


I was having the same problem, but resetting both of the settings to TRUE worked.

Thanks a lot! This did it :grinning: :+1:

security.allow_eval_in_parent_process TRUE

Never heard about that before

Update to Firefox 108 to import CSV files after setting just signon.management.page.fileImport.enabled to true in about:config.

security.allow_eval_in_parent_process should always be false!

I´m on FF 108. Do I have to reset this value?

If you changed security.allow_eval_in_parent_process you should definitely change it to false.

Disallowing eval is an important exploit mitigation.

1 Like