"Installation aborted because the add-on appears to be corrupt"

Developers should just update the requirements for their add-ons on the download page.

For example, here, you can see the different versions, back to 2017, and all of them have the same requirement (i think it’s by default automatically set by the add-ons website with a new upload) and it’s not accurate.

The add-on page checks the user’s FF version, and if the version required is not accurate it will let the download occur, and lead to this error, or even install the add-on, but it will not work.
This happened to me several times.