Add-on corrupted message on install

Hi,

I published a new add-on which passed the review.

Now when I try to install the add-on from https://addons.mozilla.org/en-US/firefox/addon/better-lists-for-salesforce/ in my normal Firefox browser, I get a message “Installation aborted because the add-on appears to be corrupt.”.

In Firefox Developer Edition I can install the add-on from the add-on store.

When I download the xpi file and try to install from file it also fails on Firefox browser. When I unzip the xpi file, then I can install it in Firefox Developer Edition.

Firefox Developer Edition 72.0b3
Firefox Browser 71.0

I tried both on Mac and Windows and experience the same issue.

Anyone has a suggestion?

thanks,
Wim

It looks like there’s a signature problem in the signed file. I don’t know why that happened. My suggestion is that you upload a new version (with a higher version number, doesn’t need to have different code) and see if that fixes the problem.

I just noticed your XPI has a bunch of empty files called Icon which could be the cause of the problem. Maybe try removing those first from your XPI.

Thanks, I delete the icon files and will try it again

Reproduced problem for my extension Medspell


Users are complaining that they are unable to install due to this error
“Installation aborted because the add-on appears to be corrupt.”

Which runs fine on my development machine FF 71 / Mint
However for new installs I can reproduce the install error on the latest stable FF 72.0.1 / win 10
the js console does not provide any additional information

The extension is mature (last touched in 2016) and it will be a challenge to find the original files and build script although I should be able to hack the XPI if its the matter of dropping a file and resubmitting at a higher version for resigning.

Please advise if that is what fixed it

I was able to install it with no problems on Mac OS. If you can reproduce the error, I suggest looking at the Browser Console for any installation errors.