Last sentence to listen not shown automatically

When I am listening to sentences in a language, I get a message after a while “No more sentence…”. When I go to the record page and back to the listen page I get (always?) one more sentence. On the dashboard I can sometimes see that there are e.g. 15 new sentences and I get exactly 14 - to get the last one I have to switch to recording and back to listening. Maybe some index problem somewhere.


Thanks for reporting.

What language are you experience this issue with? Is your user a highly active one? We have seen similar reports only from people who are extremely active.


I mainly work in Esperanto and know the problem quite well from there, but IIRC I also had it in German. And yes, I guess I am “extremely active” :slight_smile:

Pinging @dabinat here because I remember there was a similar case in the past (can’t remember who was affected).

@phire is there a way we can collect more information to diagnostic this issue and understand how to reproduce it?

@Murray_B what’s your username on the site?


@nukeador: It’s like Murray_B, like in Discourse - I didn’t want to confuse somebody. :wink:

@Murray_B Just to clarify, this issue happens when you’re on the very last sentence available to record for a given language?

@phire No, not record, listening! Say, there are 10 new sentences I haven’t checked for correctness. I get five sentences to check, just normal as you would expect it. After that on the next page I get only four sentences and after that the message, that there are no more sentences to validate left. I go to the record page and immediatly back to the listen page and voila, there is the missing last sentence!

You are 10 minutes too late, I just had it again in Esperanto, maybe I can record it next time :slight_smile:

No that’s enough information to go on, I can look at the timestamps of your last Esperanto validations :slight_smile: but I think you’re right and it’s probably just an index bug in the UI. Thanks for the flag, I’ll look into it.

Okay, I did it, this is the way it looks like:

@nukeador I can’t remember if I specifically filed an issue but this bug has existed for a long time. I don’t get it all that often nowadays in English though.

Another similar problem that is probably related is that you get a blank sentence sometimes when you skip. (Clicking Play plays the audio of the last sentence you viewed.) The only way to get around this is to reload the page.