LightBeam addon corrupt?

Trying to install lightbeam as addon to firefox.
Get red highlighted line telling me it can’t install as the add on appears to be corrupt.
Please advise - I have a screen shot/snippet if helpful to you.

Hi @sishippee, what version of Firefox are you running? You might need to update to a current version or apply a patch to be able to install the extension.

image.png

Thanks!

Can you create a new Firefox profile and see if you are able to install it on the new profile?