Lightening Download


(Michael) #1

Lost entire Linux Ubuntu 18.04 SSD. Trying to Download and install Lightening Add-on to Thunderbird 52.9.1, but download will not start. Gives error: The download from this site appears to be corrupt. Is there a problem on the Mozilla Thunderbird server end?


(David Ross - Mozilla Rep & UK Community) #2

Thunderbird is moving to its new community, as announced in 2017. Its new home is at https://www.thunderbird.net/

Add-ons recently switched over to this new home. Have you tried from there?


(Michael) #3

YES, that is the one I was trying to download.
Anything else I can try?

  Spikels6

(Walt) #4

You might need the Ubuntu distribution version of Lightning.

Try opening a terminal and type: sudo apt-get install xul-ext-lightning


(Michael) #5

WOW, that is it! Downloaded and installed easily.
I’ll make a note of the code line for future reference.

  Thank you very much. I use it nearly every day.

  Spike

(Michael) #6

That worked! I’ll keep the code line for future reference. Michael


(David R.) #7

Thanks! Ubuntu went and upgraded me to 60.2.1 today, the old version of Lightning wouldn’t upgrade for some reason. After installing that package, and removing the old extension, it started working again.


(Walt) #8

Your welcome.

I received the update from Ubuntu yesterday and I had no problem with their Lightning update. Their gdata provider update didn’t work so I installed version 4.4.2 from addons.thunderbird.net.


(Matt Harris) #9

Thunderbird has bundled the lightning add-on for a number of release versions now. Perhaps someone could ask the maintainer why the Connonical version does not contain the localises version the release on the Thunderbird.net site contains. This is an issue that can really only be fixed by the maintainers at Connonical as I must assume they are the ones who decided to role their own installer.