Macedonian Voice for TTS

I am creating a TTS for Macedonian Language. I have collected 9 hours of data and I am training a Tacotron model.

This is the alignment I get after 128000 steps. However I get noise at the end of the train file. Is this caused because of silences at the end of audio files?

This is the configuration I am using:

// Audio processing parameters
“num_mels”: 80, // size of the mel spec frame.
“num_freq”: 1025, // number of stft frequency levels. Size of the linear spectogram frame.
“sample_rate”: 22050, // DATASET-RELATED: wav sample-rate. If different than the original data, it is resampled.
“frame_length_ms”: 50, // stft window length in ms.
“frame_shift_ms”: 12.5, // stft window hop-lengh in ms.
“preemphasis”: 0.98, // pre-emphasis to reduce spec noise and make it more structured. If 0.0, no -pre-emphasis.
“min_level_db”: -100, // normalization range
“ref_level_db”: 20, // reference level db, theoretically 20db is the sound of air.
“power”: 1.5, // value to sharpen wav signals after GL algorithm.
“griffin_lim_iters”: 60,// #griffin-lim iterations. 30-60 is a good range. Larger the value, slower the generation.
// Normalization parameters
“signal_norm”: true, // normalize the spec values in range [0, 1]
“symmetric_norm”: true, // move normalization to range [-1, 1]
“max_norm”: 4, // scale normalization to range [-max_norm, max_norm] or [0, max_norm]
“clip_norm”: true, // clip normalized values into the range.
“mel_fmin”: 0.0, // minimum freq level for mel-spec. ~50 for male and ~95 for female voices. Tune for dataset!!
“mel_fmax”: 8000.0, // maximum freq level for mel-spec. Tune for dataset!!
“do_trim_silence”: false // enable trimming of slience of audio as you load it. LJspeech (false), TWEB (false), Nancy (true)

    "backend": "nccl",
    "url": "tcp:\/\/localhost:54321"

"reinit_layers": [],

"model": "Tacotron",          // one of the model in models/    
"grad_clip": 1,                // upper limit for gradients for clipping.
"epochs": 3000,                // total number of epochs to train.
"lr": 0.0001,                  // Initial learning rate. If Noam decay is active, maximum learning rate.
"lr_decay": false,             // if true, Noam learning rate decaying is applied through training.
"warmup_steps": 4000,         // Noam decay steps to increase the learning rate from 0 to "lr"
"memory_size": -1,              // ONLY TACOTRON - size of the memory queue used fro storing last decoder predictions for auto-regression. If < 0, memory queue is disabled and decoder only uses the last prediction frame. 
"attention_norm": "sigmoid",   // softmax or sigmoid. Suggested to use softmax for Tacotron2 and sigmoid for Tacotron.
"prenet_type": "original",     // "original" or "bn".
"prenet_dropout": true,        // enable/disable dropout at prenet. 
"windowing": false,            // Enables attention windowing. Used only in eval mode.
"use_forward_attn": false,      // if it uses forward attention. In general, it aligns faster.
"forward_attn_mask": false, 
"transition_agent": false,     // enable/disable transition agent of forward attention.
"location_attn": true,        // enable_disable location sensitive attention. It is enabled for TACOTRON by default.
"loss_masking": true,         // enable / disable loss masking against the sequence padding.
"enable_eos_bos_chars": false, // enable/disable beginning of sentence and end of sentence chars.
"stopnet": true,               // Train stopnet predicting the end of synthesis. 
"separate_stopnet": true,     // Train stopnet seperately if 'stopnet==true'. It prevents stopnet loss to influence the rest of the model. It causes a better model, but it trains SLOWER.
"tb_model_param_stats": false,     // true, plots param stats per layer on tensorboard. Might be memory consuming, but good for debugging. 

"batch_size": 32,       // Batch size for training. Lower values than 32 might cause hard to learn attention. It is overwritten by 'gradual_training'.
"r": 7,                 // Number of decoder frames to predict per iteration. Set the initial values if gradual training is enabled.  
"gradual_training": [[0, 7, 32], [1, 5, 32], [50000, 3, 32], [130000, 2, 16], [290000, 1, 16]], // ONLY TACOTRON - set gradual training steps [first_step, r, batch_size]. If it is null, gradual training is disabled.  
"wd": 0.000001,         // Weight decay weight
"checkpoint": true,     // If true, it saves checkpoints per "save_step"
"save_step": 1000,      // Number of training steps expected to save traninpg stats and checkpoints.
"print_step": 25,       // Number of steps to log traning on console.
"batch_group_size": 0,  //Number of batches to shuffle after bucketing.

"run_eval": true,
"test_delay_epochs": 5,  //Until attention is aligned, testing only wastes computation time.
"test_sentences_file": null,  // set a file to load sentences to be used for testing. If it is null then we use default english sentences.
"min_seq_len": 9,       // DATASET-RELATED: minimum text length to use in training
"max_seq_len": 182,     // DATASET-RELATED: maximum text length
"output_path": "../keep/",      // DATASET-RELATED: output path for all training outputs.
"num_loader_workers": 2,        // number of training data loader processes. Don't set it too big. 4-8 are good values.
"num_val_loader_workers": 2,    // number of evaluation data loader processes.
"phoneme_cache_path": "mozilla_mk_phonemes",  // phoneme computation is slow, therefore, it caches results in the given folder.
"use_phonemes": false,           // use phonemes instead of raw characters. It is suggested for better pronounciation.
"phoneme_language": "mk",     // depending on your target language, pick one from
"text_cleaner": "basic_cleaners",
"use_speaker_embedding": false,     // use speaker embedding to enable multi-speaker learning.
"style_wav_for_test": null,          // path to style wav file to be used in TacotronGST inference.
"use_gst": false,       // TACOTRON ONLY: use global style tokens

"datasets":   // List of datasets. They all merged and they get different speaker_ids.
            "name": "",
            "path": "",
            "meta_file_train": "metadata_train.csv",
            "meta_file_val": "metadata_val.csv"

Try with setting “do_trim_silence: true”

While you at it you might also want to adapt mel_fmin and mel_fmax setting, e.g. “mel_fmin”: 50.0

Do you get the same noise when generating sentences? If not then you should be fine.

That noise you will only be probably get during training time, not inference.

1 Like

noise in training time is normal due to padding