Minor issue: "New" intranet URLs don't always work

Sometimes I key in a company intranet URL, and FF runs off to google instead of browsing there. This will typically occur the first 6-10 times I browse there. It occurs even if I include “https”. Once I’ve successfully browsed there through repeated attempts, the problem goes away and everything is fine.

If I had to guess, it’s like FF says “I don’t recognize this domain, so I better google this instead”.

I hunted around for an option such as “Never google a URL you don’t recognize, just trust the DNS to figure it out” but no obvious choices.

This is not a horrible bug, but can be a nuisance for users trying to hit the intranet site. I’ve been able to produce it on Vista (Old FF), Win 8, and Win 10.