Moving firefox profile: No response / no effect

I’m having trouble moving firefox to a new computer. I copy the files, expecting to see my existing set up with bookmarks, extensions, and passwords, and I get no response, no errors, just completely fresh firefox.

Both systems are on arch linux and both running Firefox 117.0. I completely close both firefox. I copy ~/.mozilla/firefox to an ext4 thumb drive from my old computer. on the new computer, I delete the existing ~/.mozilla/firefox. I copy the files from the thumb drive to /firefox/. I restart firefox. No responce

I’ve also tried chowing the files. and also chmoding 700 and 755 (advice from old stackoverflow threads) ive tried chowing and chmoding. Each time i restart the whole process for posterity. Still no response

I’m dumbfounded as to why it’s not working, and I don’t even know where to look now


Are you sure that is where the profile was on the old computer?

Did you use the button in about:support to open the profile folder?