New add-on not appearing on AMO unless logged in


(Chuck Baker) #1

I uploaded a new extension to AMO a couple of days ago. The url is https://addons.mozilla.org/en-US/firefox/addon/paste-email-plus-for-quantum/.

But the link only works if I am logged into AMO, otherwise I get a “Page not found” message. I have posted the link on my support forum, but I don’t believe my users will be able to get there unless they have an AMO account and happened to be logged in. Is being logged in a requirement to view/install extensions?

Also, the add-on does not appear in an AMO search. If I search for “Paste Email Plus for Quantum” it does not show up anywhere in the ten pages of results. If the results are based on relevance, it should be the very first listed.

I’ve also noticed that even though I have installed the add-on in at least two Firefox installations, the number of users listed is still blank. How often does that get updated?

Is there a place on AMO that lists the newest extensions? I can see categories for “Popular extensions”, “Featured extensions”, etc. but nothing for “Newest extensions”.


(erosman) #2

There is something wrong. I am able to see the add-on but not able to review the add-on.

@jorgev One of the admins needs to check it out.


(jscher2000) #3

If you go to “Manage Status & Versions” can you confirm that the extension is set to “Visible”?

Statistics like users and downloads seem to be delayed 24 hours, so nothing unusual there.


(Chuck Baker) #4

Yes … it is set to: Visible: Visible to everyone on https://addons.mozilla.org and included in search results and listing pages. (But it is not available in search results.)


(Jorge) #5

This was solved in https://github.com/mozilla/addons-frontend/issues/4902