No matching distribution found for tensorflow==1.15.2 (from deepspeech-training==0.7.3)

I’ve been stumped at this error for quite a few days now. I’m following this guide:

When I do :

pip3 install --upgrade --force-reinstall -e .

It gives me the error:

ERROR: Could not find a version that satisfies the requirement tensorflow==1.15.2 (from deepspeech-training==0.7.3) (from versions: 2.2.0rc1, 2.2.0rc2, 2.2.0rc3, 2.2.0rc4, 2.2.0)
ERROR: No matching distribution found for tensorflow==1.15.2 (from deepspeech-training==0.7.3)

I tried doing this:

sudo apt-get install python3-dev

But it still gives me the same error. Somehow it works on google colab but I don’t want to work on colab because of my internet issues.

What am I missing? I’m using anaconda navigator python 3.6 environment, on Pop OS 20.04. If you need any other information, please tell me because I’m quite new to all this.

1 Like

Same problem here. I am also using Ubuntu 20.04 and will try again with 18.04 if I don’t fine any other solution.

1 Like

You just need to make sure you’re using Python 3.5, 3.6 or 3.7. TensorFlow 1.15 does not support Python 3.8:

1 Like

Let me know if you get this to work on 18.04

The environment I’m using is python 3.6.

Please share verbose pip install. Make sure you try with vanilla virtualenv and not anaconda.

1 Like

Ok I tried with a vanilla python3.6 virtualenv and the installation went fine. However:



ValueError: Scorer initialization failed with error code 8198
swig/python detected a memory leak of type ‘Alphabet *’, no destructor found.

Does this indicate a problem with my installation or should I go ahead?

There are two things in this message. The second is not important, the first is. Please ensure you have poperly setup git-lfs and that there’s a correct scorer file available. Error message says otherwise.

1 Like

I’ve setup git-lfs again, just to be sure and did git clone. But now it gets stuck after:

Cloning into ‘DeepSpeech’…
remote: Enumerating objects: 115, done.
remote: Counting objects: 100% (115/115), done.
remote: Compressing objects: 100% (73/73), done.
remote: Total 18750 (delta 62), reused 60 (delta 36), pack-reused 18635
Receiving objects: 100% (18750/18750), 47.78 MiB | 96.00 KiB/s, done.
Resolving deltas: 100% (12750/12750), done.

I waited for like 15 minutes before Ctrl+C. And it gives:

^Cwarning: Clone succeeded, but checkout failed.
You can inspect what was checked out with ‘git status’
and retry with ‘git restore --source=HEAD :/’
Exiting because of “interrupt” signal.

I try git restore but it gets stuck again. Nevermind, I run the rest of the commands as usual and it goes smoothly until I run that script again and get the same error. Something’s wrong with cloning, I presume. Should I manually download the zip?

PS I should add that a friend had the identical problem when I asked him to try installing DeepSpeech for verification. He was on ubuntu 19.04. His git clone got stuck too.

Could it be just your network that is slow ? 96kB/s the files that git-lfs downloads are ~900MB.

Well, we don’t get much better in Pakistan. Any alternatives?

I’m afraid there is no good solution here, except being patient.

1 Like

Alright I’ll try git clone again and wait for … some time. Thank you for your help.

Just for confirmation, the scorer required by the script is downloaded with git clone and doesn’t need to be downloaded separately?

git clone will rely on git-lfs yes, so you have no extra step after

1 Like

What you could do is to clone everything on a Google colab and repackage everything without the scorer. This way you could get the code to train now and get the scorer later.

I’m not sure if I understood properly. I cloned DeepSpeech repo on google colab and then zipped the folder and downloaded it. Now upon running this command locally on my computer:

pip3 install --upgrade --force-reinstall -e .

I get the error:

ERROR: Could not find a version that satisfies the requirement ds_ctcdecoder==training/deepspeech_training/VERSION (from deepspeech-training===training-deepspeech-training-VERSION) (from versions: 0.6.1, 0.7.0, 0.7.1, 0.7.3)
ERROR: No matching distribution found for ds_ctcdecoder==training/deepspeech_training/VERSION (from deepspeech-training===training-deepspeech-training-VERSION)

I thought your problem was the large download. This way you can reduce it to a fraction and test on Google whether everything is working so you can replicate it on your system.

I’m pretty sure the download size isn’t the issue. It’s probably a git problem. It gets stuck after resolving deltas. On Colab, I get the same error as above after running the pip install -e . command. In any case, I cloned the repo again, ctrl+c when it got stuck, tried running the ldc93s1 script which failed just like before. But other scripts in the bin/ folder are working so I’m assuming it’s a script problem.

I have no idea what you do, but it runs perfectly on colab:

!curl -s | sudo bash
!apt-get install git-lfs
!git clone --branch v0.7.3
%cd DeepSpeech
!pip3 install --upgrade pip==20.0.2 wheel==0.34.2 setuptools==46.1.3
!pip3 install --upgrade --force-reinstall -e .
!python3 util/ --target .

Check it and let us know what you did differently

1 Like

I was doing only one thing differently: I didn’t specify the --branch argument in git clone. That has made all the difference. It installs correctly. The util/ throws a lot of http errors though.