Page action disabled and popup not displayed


I am having trouble to with a page action.

I have added the following to my manifest:

"page_action": {
  "browser_style": true,
  "default_icon": {
    "19": "icons/page-action.svg",
    "38": "icons/page-action.svg"
  "default_title": "my page-action",
  "default_popup": "page-action.html"


  1. Why is the page action disabled/gray?
  2. Why is the popup not displayed on click?
  3. How do I get the icon to display in the same line as pocket, bookmark and not as an option under “page actions”?



I realize that when I add


eg. "show_matches": ["https://**"]

Then the the icon is displayed as expected and and the popup pops. However i want the page action to be available for all pages. My extension is collecting links for a link list, so I need the option to be dispayed on all pages/urls.

How do I achieve that?

I can not use a browser action as it is reserved for other features. Also collecting the link is closely related to the url in the address bar, so it only makes sense to display it there.

What if you use this host permission pattern:

"show_matches": ["<all_urls>"]