Pushover Addon Fails to Create a Thing

I’m attempting to try out Pushover as a possible replacement to Twilio. I’ve loaded the addon and made the appropriate configuration settings. I can’t get a Pushover “Thing” to be found/presented when I use the “+” icon at the right hand bottom of the things page. I’ve rebooted, removed and reloaded the Pushover addon but still no success.

The log file is giving some hints (I suspect) but this goes beyond my skill level. The log file entries are below.

Loading add-on: pushover-notifier.
pushover-notifier: Opening database: /home/pi/.webthings/config/db.sqlite3
pushover-notifier: Ignoring https://raw.githubusercontent.com/WebThingsIO/gateway-addon-ipc-schema/master/schema.json because it has no messageType
pushover-notifier: Ignoring https://raw.githubusercontent.com/WebThingsIO/gateway-addon-ipc-schema/master/messages/definitions.json because it has no messageType
pushover-notifier: Loading add-on pushover-notifier from /home/pi/.webthings/addons/pushover-notifier

Any suggested debugging approaches, fixes or work around would be helpful.

Thanks. Kevin

Hi Kevin,

I’m not sure those messages are necessarily related because I’ve seen them before when not using the Pushover add-on, but it’s possible that multiple add-ons are sending messages sending messages of a deprecated type over their WebSocket IPC connection.

Unfortunately it looks like that add-on is lacking a maintainer, but I would suggest filing an issue at https://github.com/WebThingsIO/pushover-notifier/issues with steps to reproduce your problem.


I just read the Pushover home page and it shows methods to generate pushover messages using several languages including bash…

Alternately, the “Run Program” addon might be able to execute a program that generates them.

If my memory servers me, the ability to execute the same executable using different options was not obvious, but I did not use it except to test sending snmp messages at the time…

Greetings Eric.

I’ve been looking at Pushover because Twilio wasn’t functioning. Now that I have a workaround for Twilio this isn’t as urgent for me because my use case for notifications includes a preference towards SMS. I spend a lot of time off grid and have a Zoleo satellite texting device that can receive SMS but not a Pushover. With text I can be notified of a problem and then text my neighbor via satellite if need be.

The “run program” addon was the next stop if I continued down this path with Pushover. I used “run program” recently to pass MQTT messages to AWS-IOT. You’re right… if there’s a way to modify run time options with it’s not obvious but the addon works well otherwise.

Back to the Pushover addon… I’m going to use this as an opportunity to better understand the gateway/addon coding and then report a detailed issue on the GitHub page as Ben suggests.

My apologies. I take it all back. Pushover is working fine.

Being a notification it doesn’t need to create a thing to work via the rules page. Twilio does create a thing and I was confused when Pushover didn’t.

Operator error…

1 Like