Some cookies are no longer set

I am working on an authentication platform using identity server4 as framework.

Today, I noticed that when I launch the authentication project on my workstation, Firefox Developer (96.0b10 (64 bits)) does not save two cookies out of the three required by my application. With the online version, no problem.

I tried on Chrome and Edge with the local application, and no problem.

I have disabled all extension and the active protection; I tried on a colleague’s workstation which has the same version of Firefox. In Both case, the same cookie is saved and the other two are ignored.

Below is the response from the server:

HTTP/1.1 302 Found

Date: Fri, 07 Jan 2022 14:51:53 GMT

Content-Length: 0

Cache-Control: no-cache,no-store

Pragma: no-cache

Expires: Thu, 01 Jan 1970 00:00:00 GMT

Location: /account/logged-in

Set-Cookie: abc.b=XXXXXXXXXXXXXXXXXXXXXXXXXXX; path=/; samesite=none

Set-Cookie: abc.c=XXXXX[...]XXXX; path=/; samesite=none; httponly

Access-Control-Allow-Origin: *

If you need other information, please, just ask.

Does the Web Console mention anything about it? Firefox 96 has changes related to the samesite parameter which might be relevant.

@jscher2000, no, the console is silent about this. no error is raised.

Could you test with these preferences individually toggled back to false (their Firefox 95) value, to see whether either of them independently relates to this problem? I think you need to clear cookies before each test to get a clean diagnosis.

  • network.cookie.sameSite.laxByDefault
  • network.cookie.sameSite.noneRequiresSecure

Well, I’ve been having some trouble with Firefox the last few days.
Firefox won’t start on my workstation. I try to do a clean install, but no luck.
Maybe the cookie problem was a symptom.
When I can get a fully functional Firefox, I’ll try again.
Sorry for the inconvenience.