Sonoff Zigbee Dongle

Hi all

I’ve a simple question which I’d like help with which is does anybody know if the Sonoff dongle will work with WT.

Here’s the link

Thanks in advance and Merry Christmas to all :santa::+1:

I just bought one of these and plugged it in to a fresh install of WT on RPi. As I understand it there are 2 ways to use USB dongles: directly or through zigbee2mqtt. It can’t be used directly because it isn’t in the dropdown list in the ZigBee plugin settings.

It’s listed as a supported adaptor on the zigbee2mqtt site:

So, I installed the zigbee2mqtt plugin in WT. I don’t think it’s working though as I can’t add a ZigBee device on the add-new-thing page - nothing detected.

The zigbee2mqtt site seems to suggest the firmware needs to be flashed. The dongle is advertised as working out of the box with Home Assistant so I might just try that instead.

Hi @Recycle, welcome. And hello @lodgemoorlad1 who originally raised the question.

I know that @buttonmash has recently reported success using the Sonoff Zigbee Dongle with Zigbee2MQTT. He didn’t mention having to flash the firmware. Did you need to do that @buttonmash?

There are actually two ways of using Zigbee2MQTT with WebThings Gateway at the moment. There’s kabbi’s zigbee2mqtt-adapter adapter add-on which you found, but the WebThingsIO Zigbee adapter (shipped with the gateway by default) also now works with Zigbee2MQTT if it is installed. There are instructions in the README about how to set that up. I’d like to improve that experience if we can.

I’m going to buy the Sonoff adapter to try it out as I’m interested in using it myself.

Please let us know how you get on. If it does work out of the box with Home Assistant then let’s ask them how they did that.


I tried the zigbee2mqtt-adapter because it seems to include zigbee2mqtt. I wasn’t able to get it to work, the logs suggested another process was locking the USB adapter. So I tried the default Zigbee adapter, but that meant installing zigbee2mqtt. This failed because of missing dependencies (following the zigbee2mqtt installation instructions). I may try installing zigbee2mqtt again following a dist-upgrade on a fresh Webthings install. The Webthings raspbian distro is a couple of years old now I think. ATM I’m more inclined to try HA instead.

have you disabled or removed the zigbee plugins?
both plugin can’T run at the same time