Subdomain Reclamation not working

Hi Team,

Lately I have observed that the domain reclamation while registering the gateway is not working. When registering with an already used domain, the subscribe API is failing. I had reclaimed the domain few days back, but since two weeks or so I’m seeing this issue.


  1. Register a domain.
  2. Mozilla sends confirmation email, I confirm the email address.
  3. Re-register with the same subdomain and email address.
  4. Mozilla sends the reclamation token on the email and UI has a field to input it.
  5. I get registered to the same subdomain with the tunneling service.

So far it was working fine, but now from step 4, the API call is failing and I’m not getting any reclamation token on email, nor is the UI updated to enter the reclamation token.


Sorry about that! We had a small issue in our recent localization efforts that caused this. Things should be fixed now.


Hi @mrstegeman
Things are working fine now! Thank you for the update!

I´m also trying to reclaim my domain but am stuck after entering the token and hitting create. I´ve waited for 20 minutes…

I sometimes run into the page “Processing…” being stuck seemingly forever, but behind the scenes the process usually completes successfully. Try going to the domain you just set up if you’ve waited several minutes.

Hi @kgiori,

Even I have experienced this. @mrstegeman, sometimes after registering the subdomain with the tunelling service, it’s stuck at processing whereas in the backend, the service has already restarted. If we open up a new tab and hit the subdomain, the gateway is accessible there. I could not reproduce it with fix steps. Any way I could look to debug it more?

I’ve been trying to figure out that issue for a long time, but can never reproduce it.

However, the area of code where the bug exists has been completely rewritten, so hopefully this will be fixed in the 0.10 release (or in the master branch).

After deleting my broswer history:
If I try to acces the gateway via gateway.local I get SSL_ERROR_BAD_CERT_DOMAIN after accepting the bad cert I can use the gateway as usual

I can also acces the gateway via

I thought I tried this yesterday aswell but maybe it worked today because I deleted the cache.

thanks for the help