[Support] uBlock Origin


(Graham Perrin) #740

Thanks.

Re: https://www.reddit.com/comments/8ulr8l/-/e1liit9/?context=1 it’s possible that the next release will be 56.3 (not 56.2.2); I’ll revisit this topic in due course.


(Ilike0000) #741

Our clients are experiencing issues with our product (web based) due to ublock blocking our java scripts. How can we get this resolved on a global basis?


(Major Mike) #742

That is almost guaranteed to be a list issue, not a core uBlock issue. You would have to find out which list is blocking your resources and then make your case to them for an exception on their list.


(Ilike0000) #743

Hi Mike,

We’ve had to make exceptions in our Chrome extensions as well for all of our users at our company. I manage and implemented u block origins for our environment and did this through gpo. We’ve had many clients call in to our support and constantly have to walk them through how to do it on their end.

-Lennie


(gwarser) #744

Find out which list is causing your problems https://github.com/gorhill/uBlock/wiki/The-logger#finding-from-which-lists-a-static-filter-originates and use this list support page to report problem.


(Ilike0000) #745

Thank you for the quick responses Mike!


(Major Mike) #746

As @gwarser reiterated, your best approach would be to find the “offending” filter on the list like I said and get it resolved with them. The alternative would be maintaining your own list that corrects for any issues you are facing on the organizational level but that’s a serious undertaking, I would think carefully about that. Good luck.


(practik) #747

I use uB0 to block inline scripts on Google search pages (among other things). With scripts blocked, the look of the search interface changes significantly, so I can easily see whether blocking is working.

After I updated uB0 from 1.16.12 to 1.16.14 yesterday, something strange happened: The next time I did a Google search, blocking stopped working – but only for that one search; after that it worked again for the rest of the session.

But then today when I restarted Firefox, Google blocking was not working at all. So I downgraded to 1.16.12, and Google blocking started working again. But then, as a test, I restarted FF again – and Google blocking was broken again.

Long story short, the only way I can get Google blocking to work right now is to change my uB0 version (I’ve tried 1.16.12, 1.16.14, and 1.16.15b5) every time I restart the browser. Blocking seems to be working fine everywhere else, bizarrely. Any ideas on how I can really fix this? I feel like I must be missing something obvious.


(gwarser) #748

Maybe:

  • when you have browser set to restore session on startup, page with ads may load before extension will start (this may help)
  • when extension is updating and you have opened page with ads hidden by cosmetic filters, content script from old version will be unloaded and ads may be shown. When you reload page new script will be applied and ads will be hidden.

(practik) #749

@gwarser, thanks for the suggestions! Neither of those was quite what I needed, but the mysterious problem has mysteriously gone away (at least for now).


(Ilike0000) #750

Hi - Do the whitelisted website/domains not show up anymore for end user if it’s configured through registry (GPO). I ask this because I’ve changed it a bit and force the gupdate. Looked in the chrome:\policy and registry, successfully added but nothing in the extension options. Went to a known website where we’ve had to white list but did not run into issues.

Thanks

-Lennie


(gwarser) #751

Nothing was changed in uBO. Your group policy settings should override uBO settings. I think your JSON is invalid and policy was not imported - your old uBO settings (from old policy) are still in effect.


(Ilike0000) #752

Thank you for the response. I dug into it and discovered the incorrect CRUD was put in.


(practik) #753

@gwarser, I found the source of the problem I was having last week – it was a conflict with the CanvasBlocker extension, which I’d updated at the same time I updated uB0. See https://github.com/kkapsner/CanvasBlocker/issues/214 for details.


(gwarser) #754

Ah, yes, sorry I did not come up with this. Maybe if you would mention other extension. This Firefox behavior is known for 2 months already (bugzilla 1462989) - was discussed internally with connection to uMatrix, but no official issue on uBO issues tracker exists.


(practik) #755

No need to be sorry, of course you couldn’t have known since I didn’t mention it. Thanks for helping us all out here on this forum!


(Mitch) #756

Hi. For starters I’m not at all an advance user. I am trying to save a certain homepage on my browser and after a quick search Mozilla suggested it could be an extension blocking this from happening. My only extension is UBO and I run version 1.16.14. Has this ever happened with UBO? If so, how do I work around it?


(Mitch) #757

^ I should probably mention, of course, that when I try to save a homepage my settings just reset to default after I exit the settings page. I’m not looking for a solution here if it isn’t likely to be anything to do with UBO.


(gwarser) #758

Simple check - disable uBO and try again.


(Simthanhcong03) #759

Thanks for you idea!!!