[Support] uMatrix

(Zen Fi) #47

Save your settings either file or cloud. Uninstall uMatrix. Do browser cleanup maintenance just to be sure extensions save location(s) are cleared. Reinstall uMatrix. Recover your settings.

(Zen Fi) #48

Could Easylist and Easyprivacy be added to uMatrix? uBlockO has some of the same lists (default) enabled than uM - as separate extensions there is no parsing of the lists between the extensions - therefor increases sys res. burden?

(HuMuK) #49

Which version of the Firefox do you have?

(Red Wil) #50

Oops did not say. FF rev54 (64bit) on Linux/Ubuntu
Now that you asked mybe previous versions worked better, Could not say for sure.
I will try to install uMatrix on a fresh FF
Did you figured out a solution yet?

(Sylencer90) #51

Is it possible to block specific scripts and allow only some of them?

since some of the scripts from openload are starting a download for some random ass stuff whenever i click on pause/play.

its really annoying

(Zen Fi) #52

If possible - I’d like to see uM (or uBO) to develope even further. Possible new features could be:

- http/https enforcer

- Redirect management (strip, replace, add, etc of urls)


I’ve updated to nightly 56.0a1 (2017-07-28) (64-bit)
This seems to have mostly broken uMatrix (along with other addons).

The panel shows information about requests from the current page, but only for a split second. It then jumps to what seems like the information from the previous page.
For example, if one opens a new tab and goes directly to a site, the menu will show requests, but then most will be hidden, showing mostly irrelevant requests.
The scope selector in the top left will say that the lowest scope is blank.about-scheme

If I try to go on a site like google.com, I am redirected to google.co.uk, in which case uMatrix will revert to showing the scope as google.com.
This was done with all other addons disabled.

(Raymond Hill) #54

Looks like uMatrix’s frame script is no longer loaded into frame processes (aka WebContent processes). Same for legacy uBO, and who knows how many other legacy extensions out there.

uMatrix/webext seems to work, except that it’s afflicted by other WebExtensions-specific glitches which are yet to be fixed by Firefox devs.


I can’t reproduce this bug, Nightly 30-07-17, uMatrix 1.0.1b2. uMatrix works perfectly, I couldn’t find a single glitch. What am I missing here?

How serious are these glitches? I am planning to use uMatrix for security purposes so if security might somehow be compromised, that’s a critical flow for me. Unfortunately, I couldn’t find anything about these glitches on bugzilla or github so any help is welcome. I’ll keep searching in the meanwhile.


Basically, from times to times, the rules that are applied are not those that are associated with the site you are visiting but some from another host.
I seem to be able to reproduce this reliably (using latest nightly as of now) by going to extension menu and clicking to the “LEGACY” (or any synonym, I am not using an English version). When the mozilla page loads, uMatrix applies rules from blank:about-scheme in my setup. You may need to force multi-process mode for this to happen if I understand well what gorhill said.

(Edited to quote the relevant part of the previous message…)

(Raymond Hill) #57

The one which still exists is that just hovering over the matrix cells will always reset the scroll position to the top. So if you have a long list of domains and want to set a rule for a row which is visible only if you scroll down, the matrix will jump back to the top. Bugzilla issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1324499.


@gorhill Thank you, I’ve just reproduced this bug! There is one more bug I found. uMatrix WE1.0.1b2 from github, Nightly 31-07-17. uMatrix icon on the navigation toolbar is not rendered:

STR: Create new profile, open new tab, go to about:config and disable signature pref, then go to about:addons in the same tab and install uBO from hard drive, close the current tab.

There are two errors related to uMatrix in the browser console, the one is “Unknown localization message popuptipdashboard”, another “matrixSnapshot.usersettings is undefined”. More details on the screenshots here:


This bug is not reproduced if I move uMatrix icon to the overflow menu(right click on uMatrix icon - Pin to Overflow Menu). However, the width of the overflow menu is too small so the most part of the uMatrix dashboard is not visible. I don’t know if that’s intended or not.

(Peter Gervai) #60

Just to note that this actually results pretty inconvenient things, for example this discourse uses a login which depends on external javascripts and without them doesn’t even offer some login methods, so the users coming here reportig the problem don’t even see the login to be able to actually report. Naturally everything randomly breaks, for example google search results cannot be clicked on anymore, etc. uMatrix logs show the rejections but it’s really not helping, since the reasons behind those are, um, convoluted.

Do you expect it ever to work again…?

It would be beneficial to mention its existence in the uMatrix github main readme, including the specific location and the way to install it (since it’s unsigned).

(As a side-question: why is it tagged LEGACY while it’s supposed to be webext?)


Note that uBO/webext will still be labelled as “Legacy” in about:addons, because uBO/webext is really a webext-hybrid extension. Once the legacy storage has been imported at first install by the thin legacy wrapper, uBO/webext will fully function as a pure webext extension despite the “Legacy” label.

(Paulius) #62

uMatrix became almost unusable since the latest beta (56.0b1). The pop-up width seems to not adjust to fit all the columns: http://i.imgur.com/nBF7Vbf.png

(Gothic Death) #63

With the new beta uMatrix 1.0.1b5 webextension and FF 55.0.1, the scroll bar for modifing the controls, will pop to the top once you try to edit a site setting and you just can not, since it will keep going to the top and not let you edit anything if you have to move the scroll bar down. This does not happen using uMatrix 1.0.0 and FF 5.0.1.


@m3Lith I had the same issue. Downloading the latest development version from the AMO website fixed it but introduced an issue that’s just as bad (as explained by Gothic_Death). It’s still unusable but I assume the dev version is the one that’ll get fixed first.

As @Gothic_Death mentioned, the latest WebExt-hybrid version is unusable (GIF). After reading further up, it seems the issue is already known about.

There seems to be no working version of uMatrix for FF 56; Both the legacy and WebExtension versions are currently broken.


@Gothic_Death @redactedscribe [Support] uMatrix

(Raymond Hill) #66