Thread: Add-ons not working due to certificate expiration

(Creationanima) #1

My firefox updated today to latest version. As soon as I opened it, my addons were declared useless by firefox. I removed them and tried re-installing, but the site firefox sometimes says, “download failed. check your connection” even when I have a very good internet and when the extension downloads, it says, “addon could not be installed, it seems to be corrupted.” I tried reinstalling firefox multiple times, and even downloading the extension and then opening through firefox, I still get the corrupt message.
Please help, It’s making me rip my hairs out.

46 Likes
[FIXED] Certificate issue causing add-ons to be disabled or fail to install
Ublock stopped working
Thread: Add-ons not working due to certificate expiration - FireFox ESR 52.9.0 (32-bit) and older
Themes no longer working!?
(Hareonna20) #2

I’m havin’ the same issue. None of the add-ons I need work now. It makes me want to die. FIX THIS NOW!

13 Likes
(Chad Geary) #3

Firefox team is this related to the new whitelisting process for addons?

2 Likes
#4

I’m also having the same problem. Virtually every add-on I have has been disabled for no apparent reason. I’m also completely unable to download any new ones as the message “Download failed. Please check your connection.” pops up any time I try to download any add-on.

9 Likes
(Bfopie) #5

I’m having precisely the same issue, seemingly out of nowhere. Uninstalled 66 and downgrading to 65 doesn’t help.

What the hell is wrong with you guys? Disabling LastPass? How did you think that would go over? And then allowing the browser to refuse to download and then labeling the add-ons as corrupt? Come on.

9 Likes
(Juan626) #6

Yes, same problem for me today, using FF 66.0.3. Today after an hour of using FF, it decided to deactivate all add-ons.

Trying to download the latest version of the add-on just says “Download failed. Please check your connection”. Opening the link in a new tab, the real reason is shown: “Firefox prevented this site from asking you to install software on your computer”.

Except that the site is already whitelisted. I tried to disable basically all protection in the Options, as well as the XPI options in about:config. Even though that would be a bad idea, it should allow any site to install, but it still blocks it.

I put the link into Chrome in order to download the XPI, but FF claims it is corrupted.

4 Likes
(Recumbentibus) #7

Just came here to post the same thing. Every addon has been disabled out of the blue ~20 minutes ago and there is no way to download them.

7 Likes
(Dehoog Mark) #8

Yes! Same issue here. Started Firefox and it said that my only addon (adblock) failed to work properly. Attempted to restart Firefox. Same thing. Attempted to reinstall addon and it said “Download failed. Please check your connection.”

My internet connection is fine. So I retried other adblock addons and the same error message appeared. Something wrong on Firefox’s end I believe?

6 Likes
(Axxis34) #9

Yeah, they fricking disable the AVAST Online Security Add-On … how fricking smart is that? Stupid devs! FIX THIS CRAP ASAP!

This is the perfect way to kill of the browser, since many that gets these problem WILL choose a new browser, without these problems!

9 Likes
(Quinndamonium) #10

I came here to say everything in your post. In the middle of doing something and suddenly nothing on firefox works and will not let me add on the addons I had. Please mozilla fix this, I can’t go back to Chrome it kills my laptop and Safari sucks. I need a working Firefox!

6 Likes
(K Muraki) #11

Had the same thing just happen to me. (Including the impulse to just rip and tear at my hair! :wink: )
All my installed themes just up and disappeared. Not to mention my AdBlockPlus! (I kinda forgot how annoying ads could be whenever they pop up. Which they do. A LOT!)

Firefox and you nice people at Mozilla, please help!!!

5 Likes
(christopher) #12

why would mozilla think this is a good idea? why cant an algorithm be implemented that would check for add-on security instead of sifting through each and every add-on themselves. seems a bit counterintuitive and it also seems like many people are annoyed

5 Likes
(Vold0) #13

same here, no adblock or even browser theme. if this is not bug, but new fox politics - bb and hello chrome.
btw i use fox for a ~13 years, and now this.

5 Likes
(Thenewteddy) #14

I am also having this problem. I’ve been thinking about switching to firefox due to problems in the browser I’ve been using for over a decade; this is not the way to encourage me.

to summarize:

all - or almost all - extensions have stopped working
and
all - or almost all - extensions can not be downloaded

3 Likes
#15

Yeah, not cool. My only - and apparently dangerous - add-ons (ublock, lastpass, and push to kindle) are gone, and as others have said, I can’t reinstall them. I’m streaming music right now so I know there’s no internet issue. Please fix this.

3 Likes
(Chasenina1) #16

YEAH WHAT THE HECK MAN?! Please fix this.

2 Likes
(Selwyn J Ral) #17

I am having the same trouble as everyone else. I open up my Firefox browser and all of sudden my add-ons are gone. When I attempt to re-download my add-ons it says I have no internet connection? Except that I am streaming and able to post here?
Its frustrating because I have been making the gradual switch from the Google giant and Firefox was a great alternative. Firefox and Mozilla let me down today.

4 Likes
(Ryan) #18

Very strange, it rebooted for me in the middle of what I was typing. No warning or nothing. Lost all my addons except 1 (WebRTC Leak Shield).

1 Like
(Nrothberg) #19

I’m having the same problem. what gives!?

1 Like
(Jackuul) #20

I also have experienced this issue across my work and personal machines with different versions. As of now, only my 64 bit firefox has its extensions. All of the 32 bit installs are extension-less now.

It’s as if “someone” snapped their fingers and wiped out all of the extensions.

4 Likes