Thread: Add-ons not working due to certificate expiration

Suddenly, just a few hours ago, I can not use my signed obfuscated extension. What’s wrong ? Isn’t it stated that this will go into effect on June 10, 2019 ?

3 Likes

Are all Add-On apps on hold now? I just get “Download Failed. Please check connection” while clearly online.

2 Likes

thank you!, I literally step out for an hour and they disappeared, then found its way into the depreciated apps folder.
if its any help, overbiteWX was the only app that didn’t move into the legacy extensions folder…

14/16 of my addons. Even vue.js dev plugin, noscript and stylus.
I have only Fire drag and IMDB search working.

is this fixed yet? :slight_smile:

WTF FIREFOX!!! So how am I supposed to access all my websites with NO PASSWORD MANAGER!!! I got a business to run here I don’t need this bullshit! You just lost a long time user if this shit isn’t fixed like yesterday! Unbelievable you people have no concept of wtf you are doing to your users, obviously.

5 Likes

Firefox has a real problem. You’ve blocked Bitdefender (only the second most effective anti-virus on the web), and Startpage (one of the first sites to recognize the dangers of internet data-gathering and actually DO something about it!)??? Not to mention Adblock (who DOESN’T run Adblock?), my picture zoom utility, my video capture utility… All but one of my add-ons got nerfed by your last update! WTF?

I came to Firefox because it wasn’t “more of the same” crap from the establishment developers. I’d expect treatment like this from Microsoft or Google. Not from Mozilla. Guess I was wrong!

Any suggestions out there? What can I replace Firefox with that isn’t slaved into the Microsoft/Google/Apple multiplex? Does Linux make a browser that will run on Windows?

3 Likes

A certificate expired. It’s a huge goof. Conspiracy theories are not needed.

5 Likes

The gall, when they even post “Firefox is not made for profit, its made for its users.”
Well if you care that much you have till the end of the weekend before I scrap Firefox period.

Can’t believe I actually recommended this to people.

3 Likes

Temporary fix via /r/Firefox: https://www.reddit.com/r/firefox/comments/bkfg4f/is_there_no_way_to_force_the_disabled_plugins_to/emgaxhf?utm_source=share&utm_medium=web2x (worked for me in Ubuntu 18.04).

1 Like

On my system, the issue appears to have disabled the extensions for Edge browser as well, suggesting it may not be an issue limited to FireFox.

Just went to a site that is famous for ads… and didn’t see one… and yet I get the same “Add-on disabled” messages for the two I use.

May have been lucky though…

Hey folks! This was due to a certificate issue and the team is currently working on a fix.

You can track progress on this thread: Certificate issue causing add-ons to be disabled or fail to install

6 Likes

so any idea how long we have to wait

Not yet, but I’ll update the other thread when we have an ETA.

1 Like

why don’t you try Linux?

Seems like everything has been affected.

1 Like

At least i’m happy to know i’m not alone in this one. That thing scared the crap out of me. Couldn’t find information in any blog post or social media. Hanging tight with you guys for a solution.

4 Likes

it happened to me during the middle of a session
i legit got a chill down my spine when the notif showed up
i am actually frantic over this

I’m really fixing to stop using FF period. Add-ons not working, adblock not working, theme disabled. I tried to also go back to FF 65, but the dang thing kept auto-updating and I didn’t want it to do that. Frustrating. I’ve been using FF since I started with the computer back in 1995…Come on people, get your act together.

2 Likes