Thunderbird 45 not sending from addon

I have an addon that worked fine until I updated to Thunderbird 45. Now Thunderbird won’t send the email. When necessary it creates the dialogue box but it just won’t send the email.

The addon is singledomain@graeme.henry

Has there been a change in the way window.arguments[] are handled?

1 Like

I found out that this was the error message.
Timestamp: 18/04/2016 13:50:54
Error: An error occurred executing the cmd_sendButton command: [Exception… “[JavaScript Error: “SingleDomainSendMessage is undefined” {file: “chrome://singledomain/content/singledomain-overlay.js” line: 51}]’[JavaScript Error: “SingleDomainSendMessage is undefined” {file: “chrome://singledomain/content/singledomain-overlay.js” line: 51}]’ when calling method: [nsIController::doCommand]” nsresult: “0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)” location: “JS frame :: chrome://global/content/globalOverlay.js :: goDoCommand :: line 100” data: yes]
Source File: chrome://global/content/globalOverlay.js
Line: 103

This is the line from the singledomain-overlay.js
if (!SingleDomainSendMessage) {

var SingleDomainSendMessage = SendMessage;

var SendMessage = function() {

    if (!SingleDomain.check()) {



    SingleDomainSendMessage.apply(this, arguments);



I was having this same problem too…I figured out that the plug-in “Check and Send” was preventing e-mails from sending. Once I disabled the plug-in, e-mails are sending again.

I have found a solution.
var SendMessage = function() {
SendMessage = function() {

Solved the problem. If you can find this is the other addon you may be able to fix it for yourself.