"Tunnel not set" or https problem (general problem with connectivity)

I wonder how I can set the tunnel name and enable https on my newly setup raspberry pi (with tp-link lte modem as base station). First time around it didn’t work and I have tried the various suggestions in this forum to initiate the setup again but unfortunately neither did help.

I’m actually wondering, if the raspberry pi can even make a connection to the server for gateway resolution or download of app/other add-ons. Do I need to open specific ports on the router? Or could the connection speed (which is indeed not very high and sometime even blanks out at this location) be the reason?

Thanks for your help!

PS: I had the exact same raspberry setup at a different location before with a cable modem and everything (always) worked fine without troubles.

I believe that your gateway is having connection issues. In your other post about the DateTime add-on, I noted that it was failing to connect to pypi.org. I’m guessing that either DNS resolution isn’t working on your gateway, or that its internet connectivity is completely broken.

To answer your question directly, no, you don’t need to open any ports on your router. The connection speed could be at least part of the issue.

Thanks for the answers. I’m wondering what I could do, to get https (and my domain) back up running again. Should I try with a new setup or is it better to use the existing and restart (but how?) this process.

I’m confused about what happened. You tried to set up your subdomain, and it didn’t work, so did you click the Skip button?

Yes. So locally I’m quite happy but remote access is not possible.

Ok, you can get back to the subdomain form by doing the following:

  1. SSH into your RPi
  2. Run the following:
    sqlite3 ~/.mozilla-iot/config/db.sqlite3 "DELETE FROM settings WHERE key = 'notunnel'"
    sudo systemctl restart mozilla-iot-gateway
  3. Navigate to http://gateway.local, and you should be presented with the subdomain form.
  4. If you’re reclaiming a domain you used before, make sure you enter the same subdomain and email address combination you used the first time.

Great. Did that and it was possible to reclaim my domain and now I can connect to the gateway via that domain. This worked for me.