Unable to login into https://chat.mozilla.org/#/room/#amo:mozilla.org - Getting SSO error

Hi,

I am unable to login into Mozilla amo chat room
https://chat.mozilla.org/#/room/#amo:mozilla.org

I am receiving a SSO error as follows:
image

Thanks

1 Like

Same here. Tried every available log in option (e-mail, github, ff account), but everytime I get only “Oops!” error.

Is there someone I could contact to diagnose and resolve this issue?

+1
I have the same problem.

It keeps sending me back to email.

I’m just unable to log in to chat.mozilla.org at all.
I use my github account.

I’m presented with the sso button. clicking it just brings me back to the login page.

Which client and version are you using? Or is this just over the web version on chat.mozilla.org?

Did you log-in in the past successfully using the same method (github)?

Update: SSO was having some issues with new logins, which is now resolved as of yesterday. Can you please try again?

Thanks!

I contacted modular.im and got more detail on what the problem was that caused this. Rick at modular.im writes:

At a very high level, there was a change in one of the Riot framework libraries that led to the final URL of the SSO login flow from being malformed. Resulting in an incomplete login flow for some users, on some routes (until they refreshed / tried to access the client page again).
This, unfortunately was quite a difficult failure mode to spot. However, we are currently investigating how best to automate full end-to-end testing of these login flows in order to avoid and spot these types of failure in future.
We’re also extending our in-house usage of SSO for Riot/Matrix in order to make sure that we’re fully “dog-fooding” these features. This is quite a specific case, but it would have given us better insight in to what was happening here and would have helped us to catch it much earlier on
Investigation is still ongoing

1 Like

Here’s a doc with the root cause analysis of what happened here.

I am also unable to login.

Hello,

I am unable to log into Mozilla’s chat room as well. Just like @Pat_Callahan I am taken back to the login page displaying ‘‘Welcome to Element!’’. Since this conversation was started in March, I wanted to know whether the problem was fixed. If so, could anyone tell me if I need to do something in particular in order to access Mozilla’s chat room?

Thank you,
Anastasya N. Morozovna