Webextension works in Firefox but not with Firefox ESR


(Tensoja) #1

Hi,

I have an extension running normally in versions 57+ of Firefox and in the ESR versions it does not install.

I’ve been reading about signing issues but this seems to be okay. That way I really can not imagine what it can be.

Addon:
https://addons.mozilla.org/en-US/firefox/addon/clearcache/

The code:

If anyone knows I thank you in advance.


(Martin Giger) #2

I assume that is because browsingData was introduced with Firefox 53 and ESR is based on 52.


(Tensoja) #3

Hmm, that’s true Martin. With this change to webextension it became very difficult to maintain for all these versions.

At the moment I have reports of several users with this same type of problem.


(Martin Giger) #4

You do still have minimum/maximum version tools at your disposal to avoid people being able to install the extension on versions where they will not work.