📢 WebThings Gateway 1.2 Alpha available for testing

Hi everyone,

:loudspeaker: I’m pleased to announce that a WebThings Gateway 1.2 Alpha pre-release is ready for community testing.

The major changes in this release are a new groups feature, and compliance with the latest W3C WoT standards. Please see the GitHub release for full release notes.

There are multiple ways to test this pre-release:

  • Raspberry Pi image - can be downloaded here
  • OTA update - To update an existing 1.1 gateway running on a Raspberry Pi, see the instructions on the wiki on how to enable automatic upgrades to pre-release versions. (Please do so at your own risk as this release is not yet well tested and it’s possible it may put your gateway in a broken state.)
  • Docker image - Run docker pull webthingsio/gateway:1.2.0-alpha.1 and follow the instructions on Docker Hub to launch a container, being sure to specify the 1.2.0-alpha.1tag (Note there is a known bug with the docker image for fresh installs)

:warning: CAUTION: Using pre-release versions on production gateways is not recommended.

🪲 Please report any issues you find on GitHub, with steps to reproduce, and note that you’re using the 1.2.0-alpha.1 release. See here for known bugs and workarounds.

Your testing of this release will help identify any bugs before an automatic update is pushed out to all users. Given the significant API changes that have happened in this release in order to comply with W3C standards, it’s particularly important to test the release with as many add-ons as possible, to check for any unexpected regressions.

A huge thank you to all the members of our community who have already contributed to WebThings Gateway 1.2.

Your Milage May Vary… An Alternate test method.

Not tested yet with 1.2 Alpha, but working with version 1.1.0, the following method is what I use for testing.

I run a stock minimal image on my RPi 4B, to boot from the sdcard. I then create a bootable 32GB memory USB stick with the image of the the WebThings Gateway V1.1.0. Same as you would with an sdcard.

Then you have to setup the RPI to boot from USB memory, the following is useful if you have never tried this,

Viola. A bootable USB memory stick. If you stuff up, you simple shut down the RPi, remove the USB memory stick, easier than the sdcard, create a new image, plug it back is and off you go. My latest install has been running without fault for about 6 months. Best to use a USB3.0 USB memory stick, USB2.0 is too slow.

Cheers everyone.

Here is the procedure I use to test images using docker. The start script is basic and does not include zwave adapter definition. Only takes a few minutes to load and test…

Eric Edberg

docker pull webthingsio/gateway:latest

docker tag webthingsio/gateway:latest webthingsio/gateway:1.2a

docker images
webthingsio/gateway                               1.2a             65d8cd5ea1b9   38 hours ago    1.1GB
webthingsio/gateway                               latest           65d8cd5ea1b9   38 hours ago    1.1GB
webthingsio/gateway                               1.1.0            27dfd8ef7bac   14 months ago   1.04GB

sudo mkdir /home/webthings12a
sudo chown ele webthings12a
sudo chgrp ele webthings12a

# stop running webthings
docker stop a8416797c75a

# copy current persistent volume to new test location
cd /home/webthings110
find . -print | cpio -pdumv /home/webthings12a

# start production webthings

# update start script
cd /home/ele
cp start_webthingsio_gateway_110.sh start_webthingsio_gateway_12a.sh

# only has basic options and maps ports so they don't conflict with production

docker run -d --restart unless-stopped \
        -p 7080:8080 \
        -p 7443:4443 \
        -e TZ=America/Chicago \
        -v /usr/bin/nc:/usr/bin/nc \
        -v /home/webthings12a:/home/node/.webthings \
        --name webthings12a webthingsio/gateway:1.2a

ele@elelinux:~$ docker ps | grep web
5dd87c066001   webthingsio/gateway:1.2a                                    "/init.sh"               8 minutes ago    Up 8 minutes  >4443/tcp, :::7443->4443/tcp,>8080/tcp, :::7080->8080/tcp                                                  webthings12a
43323fbbb988   webthingsio/gateway:1.1.0                                   "/init.sh"               23 minutes ago   Up 23 minutes