WebThings on iPad2

I have an iPad2 sitting around collecting dust. I figured I would use it as a dedicated interface for WebThings. When I try to login I get the “Cannot POST /login/” error. Is my iPad2 completely worthless, or is there a workaround I’m unaware of? I have tried on Safari, Firefox and chrome all ending the same way. iOS is limited to 9.3.5 for reference.

Hmm, that’s odd. Two questions:

  1. Are you able to log in from a browser on another device, e.g. laptop or smart phone?
  2. Are there any errors in the log when your login fails? The log exists on the Pi at ~/.mozilla-iot/log/run-app.log.

Thanks for the reply! I am able to login from other browsers without trouble.

Having issues accessing the logs. If I am doing it correctly, it says Permission Denied.

I was able to access the logs and there are no errors showing. Everything else is still working as it should.

Hmm, the oldest simulator I can get on my Mac is for iOS 10.3.1, nothing 9.X. If you have a Mac, you can debug Mobile Safari as follows: https://appletoolbox.com/use-web-inspector-debug-mobile-safari/

Unfortunately I dont have a Mac to do any debugging. I’ll keep working at it and update this post if I find a solution.

Thanks for your help!


I have been having a similar issue with trying to load the Webthings gateway on my iPad Mini gen 1, running Safari 9.3.5. It loads on all my other devices.
Can’t run the web inspector on my PC, but this is basically the issue:

  1. Loading the gateway leads to a blank light blue screen. “Request Desktop Page” doesn’t work.
  2. Manually loading …mozilla-iot.org/login/ gets me to the login page, but instead of the blank fields being labeled “username” and “password” they appear blank
  3. Submitting login information leads to an error “cannot POST /login/”

It seems to be an issue specifically with Safari 9.3.5.

That seems like an issue with Fluent, our localization library. I just added (to our development branch) a library which should add compatibility for older browsers.


Sorry to revive a kinda dead thread but I came across this problem myself. Both the gateway and my own web based management code won’t work on ios/safari 9.3.5.

Instead of coding for older browsers I installed the real vnc client on the iPad 2 and connect to my hub/raspberry pi that way. I then use chrome on the pi to hit the gateway. Every thing works, no muss no fuss. Just set real vnc to take touch inputs.

It may be worth trying out so those old iPads can get put back to work.

My Ipad 1 also won’t open the UI :frowning:

It still does not work with older iPad’s. The interface gives a blue screen without the login fields. I tries on several iPad devices IOS 9.3.5 and 10.3… Not on Safari, Firefox, Dolphin, My browser and other’s I tried. I hope there will be a fix so I can use my old devices as a interface.

Hi @pepijn, welcome.

Unfortunately Apple limits the browser engines that can be used on iOS to their own WebKit WebView, so all browsers have to use their same outdated engine. Apple are pretty good at updating older devices with the latest version of their OS, but sounds like some very old devices are stuck on iOS 9.x.

As I understand it there are some newer web technologies being used by the Fluent localisation library which aren’t supported by these older browsers. It sounds like there was a fix available for this, but I’m not sure whether it got applied to the master branch.

Two things which could help move this forward are:

  1. Is this fixed on the current master branch of WebThings Gateway? This would require someone building WebThings Gateway from source to test on one of those older iPads https://github.com/WebThingsIO/gateway/
  2. If not, what errors are being reported? This will require someone with knowledge of Apple’s developer tools to access the developer console on iOS on an older iPad, if possible.

If it fixed on master, then it should be fixed in the upcoming 1.1 release. If it isn’t, then let’s try to find a fix.