Add-0n shortcuts

Apologies ahead of time- I am 82 years old, with basic computer knowledge, seldom have issues until this past week. Firefox did an auto update (I now know to turn that off in the future) to version 110.0 (64 bit). That update created chaos that I did not discover in time to do an adequate system recovery in order to get my previous version back. The previous version (109.0 ? ) worked beautifully. My add-ons, extensions, etc all worked and had shortcuts visible to Roboform, etc. The new update totally changed and removed my add-ons, theme, extensions, etc. My system recovery will only go back to 02/14/2023, so I had to go to Firefox and down load V.109.01. That still did not look familiar, but I tried to work with it anyway. I finally got Roboform to install, but I don’t know if it’s going to bring back all of it’s data. The main issue I have is that I cannot get any shortcuts to my add-ons to show up on the toolbar of Firefox. In the page that shows my add-ons management, it indicates that all of my add-ons “do not have shortcuts”. So, how can I get shortcuts to those add-ons?

I appreciate your time and understanding, as well as consideration for my age and lack of complicated computer management. I taught myself what little I do know, and seldom have problems. I’ve never had a virus or hack of my computers since I first started learning (1998).

Thank you for any assistance or guidance. I did read the blog about add-on issues, but saw no resolution to my specific issue.

Sally Thomas

Sometimes you just have to restart PC, that can help with random issues like this.

But did you lost all your addons? If you visit “about:addons” page, will it show your addons?

Yes, I have rebooted several times, including trying a system recovery (which did not allow me to go back far enough to obtain the workable version of Firefox.

I am able to insert the add-ons (spell/grammar checker, allow right-click, Roboform). However, the notation on the page states these items “do not have a shortcut”, and no matter where I search I cannot find a fix for that. The add-ons don’t show up on the Firefox menu, nor do they show up when trying to use Roboform. Thus far, everything points to an issue that was caused by the most recent update of Firefox (v 110.0 64 bit). I tried installing V 109.0, however that did not fix anything at all.


Downgrading is unlikely to help. Firefox upgrades are released every 4 weeks and are pretty small. Sadly, sometimes something breaks during the upgrade.

Could you open “about:profiles” page to see how many profiles your Firefox have?
There should be only one, but maybe you have two now.

Also, are you sure you didn’t clicked some “Firefox Reset” button? Check if there is a new folder on your desktop called “Old Firefox Data”.


I have searched and cannot find “about” in the page. Forgive me, I just turned 82 today and it may be my age preventing me from locating “about”. I usually have no problem finding that on other programs. Also, I did not change anything to cause this issue of the lack of shortcuts to add-ons. The add-ons are there, but not accessible via any shortcuts.

I did not click anything called “reset”. This issue just came up when the latest upgrade happened. I am not happy with the results of the upgrade and wish I had checked the “do not auto upgrade” before this nastiness happened. Why “fix what isn’t broken”. Not a good job by Mozilla. I need a workable Firefox back.\


Oh wait! I just found that file folder “Old Firefox Data” on my desktop. Sorry about missing that prior to my earlier reply to you. What do I do now?


Hello again,
The “about:profiles” page can be visited if you type “about:profiles” in the addressbar (instead of URL).

In any case, let’s do this:

  1. open Firefox
  2. visit “about:profiles” page
  3. click “Create new profile”, give it a name and click Next, Next to finish the process
  4. now you should see a new profile with a name you gave it in the list of profiles (in the about:profiles page)
  5. click “Open folder” in the row that starts with “Root directory”
  6. new folder will open - delete those file in there:
  7. now copy everything inside the “Old Firefox Data” folder into this empty folder
  8. close Firefox and when you open it, it should open your old Firefox

Don’t disable auto updates!
This was not caused by update, somehow you have used “Firefox Reset” to reset your Firefox.
Good luck and happy birthday :slight_smile:.
I hope this helps!

Well, I worked on this all day and still have the same issue(s). Roboform (and another add-on called Spell checker) still do not have shortcuts and don’t show up on the toolbar/menu to make them accessible.

I did not even turn on my computer for 2 days, during which time the problem arose, so no, I did not click ANYTHING, including “Firefox Reset”.

I have tried to import my Roboform data into Firefox as it was before. It shows up when I open the page “add-ons”, but still indicates that there is “no shortcut”.

I am extremely frustrated at this point because now I have to physically type in all of my information that used to be easily inserted via Roboform.

Now what?