Great work! All your tasks work correctly. I just have some comments how you could make your code simpler:
In general you should try to consistently indent your code. This will greatly improve the readability. To see how good indention looks like you can format your code on CodePen:
Task 2: I would suggest using a separate condition for machineActive like you did in task 3. You could also remove the first half of the score condition, since for example score <= 39 also matches score == 20.
Task 3: Your switch condition can just be switch (true).
Task 4: The password check should be inside the if branch. (Only check the password, if the machine is turned on.)
Task 4: You could put pwdResult = in front of the condition:
pwdResult = pwd === "cheese"
? "You have logged in successfully!"
: "Your login attempt was not successful!";
I hope that helps
@santisica29: Your email address is visible in your post. It ended up in the optional “name” field of your profile. I recommend removing it.