Brand New IOT Gateway Is Missing Add-Ons and Other Things

First, I need to apologize for any dumb statements as I am a complete noob to Pi, Linux and IOT.

I have been attempting to get Mozilla Gateway running for 3 days now. I’ve flashed a clean version of gateway-0.7.0.img (using balenaEtcher) numerous times so that I can re-try from scratch each time. While I have been able to get the gateway to connect to a Z-Wave switch, there are numerous features that simply aren’t working. These are:

  1. After configuring a wi-fi network and connecting to it, I can get to the http://gateway.local site (but only because I added a manual hosts entry as mDNS isn’t available on my router). However, for the first screen when it prompts to “Choose a secure web address for your gateway” I put in my chosen name (one word) and my email address then click on {Create]. It then shows “processing”, but then hangs there. I’ve waited for 10 minutes and still nothing happens, so finally I click on [Skip]. I’ve tried this with a 3 iterations of a brand-new clean image on my SD card.

  2. Once I skip the initial config, I can get to the main interface and I can scan and add my Z-Wave switch (by using the Z-Stick Gen5 USB dongle). However, when I go to Settings, the following pages don’t work:

    a. Clicking on “Add-ons” > (+) goes to http://gateway.local/settings/addons/discovered, but it’s just a dark blue background with a title of “Discover New Add-ons” and nothing is ever displayed.

    b. When I go to “Updates” it shows “Updates” in the title, but then with just two dark blue boxes with no text in them.

Any input as to why I can’t get this thing to work would be greatly appreciated.

That sounds like it’s having trouble connecting to the internet. Do you have DHCP available in your network?

Martin, DCHP is enabled and the Pi gets an IP address. I did move it into the DMZ so that no ports are being blocked and then I re-flashed the SD card and tried again. This time was almost the same result (can’t “Choose a secure web address for your gateway” and can’t see anything under Add-ons, but now I do see the Update version info. That’s the only change I see by moving it to the DMZ. I can’t think of anything else to try.

BTW, do you know how to install add-on’s via the Pi command line? If so, that might at least help me get over some of my hurdles.

I wonder if there’s anything in the logs (Settings → Developer → View Logs).

To load the available add-ons however can also fail in your client (the browser), since it will try to load https://api.mozilla-iot.org:8443/addons?api=2&arch=linux-arm&version=0.7.0&node=57&python=2.7,3.5 from the client. You can see that if you hit F12 and go to network, then go to the install add-ons screen.

I encountered that “Processing…” (never finishing) bug and reported it and @mstegeman fixed it. As a workaround, you can just open a new tab and enter the new subdomain url. But first wait a few minutes for the secure cert to be installed. If you don’t see add-ons listed, then either the RPi can’t get to the Internet or the special port it uses to fetch the add-ons is blocked.

May that be related to firewall restrictions, I remember from mozfest that all ports but ttp/s 80/443 were closed, so the addons list was not able to be retrieved and we were stuck to use some adapters… I might have reported this somewhere…

Hi,
I am having similar issues as @bigmac.
I am new to Mozilla WebThings and have succesullt flashed my microSD using balenaEtcher with gateway-0.12.0.img but I get several issues duing the setup:

  1. I can get to http://gateway.local no problem, but when I get to setting up a subdomain I always get the error ‘failed to get certificate, please try again’ no matter what I try I can’t get this to work so click ‘skip’.
  2. I can’t see any available smart devices which are all Wi-Fi based and connected to the same 2.4GHz network as the pi. I tried to search the Add-ons > + to see if I was missing one but the list of available Add-ons never populates. I see that the page is attempting to connect to https://api.mozilla-iot.org:8443/addons?arch=linux-arm&version=0.12.0&node=64&python=2.7,3.7 but still no list of Add-ons.

Any ideas? I note that @rzr mentions possible firewall restrictions on the port, does anyone know which port is needed so I can ensure it is open to the pi?

Any other help greatly appreciated as I’d love to give this a go as it seems like a great project.

Hi,

I think you are using the old mozilla image. The current webthings.io image is here --> https://webthings.io/gateway/

I believe the backend for mozilla-iot has been shut down.

I get exactly the same issue as sutcliffe.ben
There are no Add-Ons listed, on a brand-new gateway with the webthings.io setup.