Cannot find HomeKit addon in Things Gateway

#1

Hi~

I have just setup a Things Gateway on my raspberry pi, and I am currently trying to connect it with Thingy52 and Ti’s SensorTag through BLE. I think the homekit add-on may allow me to do that. But I couldn’t find it in the add-on discover page. In fact, I have compared the list shown on my browser with the one on the github, and mine seems out-dated. I would like to ask how can I find a way to update the available add-on list, or should I manually install the add-on?

Thanks a lot!

0 Likes

(Michael Stegeman) #2

The HomeKit adapter will not allow you to add the thingy:52 or the SensorTag. Those are BLE devices, but not HomeKit devices.

However, if you still want to add the HomeKit add-on, browse to Settings -> Add-ons, then click the + icon at the bottom right. If it’s still not there, try refreshing that page.

0 Likes

#3

Thanks for your reply. I have tried refreshed that page for a day yet the homekit still doesn’t show up. So is the list stored locally?

And I see Thingy 52 is in our supported hardware list. Could you please tell me which plug-in I should use to connect to that?

Thanks~

0 Likes

(Michael Stegeman) #4

No, the list is pulled from a server. What version of the gateway are you using?

To use the thingy:52, you can run the following to turn it into a web thing: https://github.com/hobinjk/webthing-thingy52

Make sure you have thing-url-adapter (Web Thing add-on) installed, then you should be able to add your thingy:52 to the gateway.

0 Likes

#5

I am using the current 0.7.0 and I also couldn’t find web thing in the add-on list.

0 Likes

#6

Update: I just tried the provided 0.6.1 image. It does have the webthing add-on pre-installed. Yet, I still couldn’t add the Thingy52, and there is nothing shows up in the add-on discover page.

0 Likes

(Michael Stegeman) #7

Did you run the webthing-thingy52 script I linked to above? You’ll need to have that running in parallel with the gateway before you can add it.

0 Likes

#8

I also would like to know how to get access to HomeKit as I do not see it available at all either

p.s. I’m up to date with IoT v0.7.0

0 Likes

(Michael Stegeman) #9

@netweb What platform are you running the gateway on, i.e. what OS, what Node version?

0 Likes