Can't change "invisible" setting

Hello,

After a first review of my add-on (flus) being rejected (i.e. the extension is for being used with a service which was closed at this time), I’ve set its visibility to “invisible”. For the launch of my service, I decided to distribute the add-on myself with a custom update URL.

Now my service is opened, I removed the custom update url and I was going to publish a new version, on AMO this time. Unfortunately, it says to me

Your add-on is currently set to “Invisible”. While in this state, “On your own” is the only distribution method available.

What I understand is that I need to change the visibility, but I can’t find the setting (I think I clicked almost everywhere…)

I found two similar subjects on the forum:

Some older subjects suggested to delete the extension, but I think it’s no longer needed.

Could you help me to set the visibility to “visible” and so publish my add-on? Thanks!

My computer is in spanish but I think you should be able to find it from this anyway.
In the left sidebar go to the link that says “Manage state and versions” and then the control is front and center

Unfortunately, it doesn’t appear for me

I’ve searched in the source code of AMO to understand why I don’t have this panel. I found the template file of the versions page. The setting is shown only if has_listed_versions is True, which is set if latest_listed_version_including_disabled is not empty, which is filled with addon.find_latest_version(channel=amo.RELEASE_CHANNEL_LISTED, exclude=()). This method most probably returns None, but I’m not sure why:

  1. the addon should have an id since it’s created
  2. it is not deleted
  3. so my last guess is it has no versions in channel RELEASE_CHANNEL_LISTED… but how would have been able to have the setting displayed initially? and it looks like I cannot publish any new version in this channel since… well, AMO forbids me to do so :wink:

This sound like a bug to me, what do you think?

Hi Marien, mine looks like yours for my only hidden extension. You may need to upload a new version to change its visibility.

That’s what I thought first, so I uploaded the 0.6 on Tuesday which removes update_url.

Hi @Marien, were you able to resolve this?

Hi @caitlin, no I wasn’t. I took a holiday instead of searching :grin:

I just tried another idea (I removed the browser_specific_settings.gecko.id key from my manifest, so I added it back), but still nothing :confused:

Makes sense – hope you had a restful holiday! :slight_smile:

We did some digging, and it looks like you hit a bug in AMO. It might take us some time to fix the issue itself, but in the meantime we’ve set your add-on’s status back to Visible. You should be able to submit a new version to be hosted on AMO now.

Let us know if you run into any more problems!

Hey @caitlin! Thanks a lot, it worked. I’ve been able to upload a new version on AMO (which has been approved :white_check_mark:) and now the “visibility” section is back :slight_smile:

1 Like

Hey @caitlin, I just hit this exact same bug, but after uploading a new version the visibility section in “Manage Status & Versions” is still missing for me. Is there something I can do now?

(I uploaded a new addon, saw it was flawed, so I disabled it and deleted the version, then fixed it and uploaded a new version, but couldn’t change the visibility setting neither before nor after uploading the version.)

Edit: The issue on GitHub that you linked @caitlin describes the exact same scenario that I encountered, including the way to achieve it. Could you please also reset my addon to visible? :grinning: