Can't submit addon: nothing happens after Describe step

So I’ve written an addon and want to submit it. I follow the steps on extensionworkshop.com , and all goes well, no errors. I upload my addon, upload the source code, and then comes the “Describe Add-on” page. I fill out all the (necessary) fields, and press “Submit version”, and I’m back on the same page. There are no errors, but it doesn’t go to the next page as described in the instruction! No matter how many times I press, nothing new happens.
I’ve tried deleting the addon, then rebundling and resubmitting anew, but still the same thing happens.
Addon name is pure-image-redirecter, also it’s on github here

Hi @d86leader, sorry for the inconvenience! We looked into this and it looks like some additional information in the “Describe” step that appears to be incomplete. Could you try it again? If you want to post or DM me a screenshot of the subscribe page, I’m happy to double-check that all fields were filled out.

Thanks for your reply @caitmuenster ! I tried again filling all the text fields this time. Here is the screenshot of the page after I pressed Submit. I wonder if it uploaded correctly.

Thanks @d86leader! This looks like a bug. Can you file an issue for this and include the URL of this page? We’ve seen some issues related to localization in the past and I’m wondering if this might be related.

So if anyone comes here from duckduckgo in the future, the issue page is here, and the issue was in the archive extension: as of now AMO rejects .tgz archives for source code, but accepts .tar.gz