Cannot submit details for new extension

(Linus) #1

I’m trying to submit a new extension to AMO, but am hitting a brick wall when trying to save the extension details. After filling everything out and pressing “Submit Version”, I’m simply taken back to the same page, with my stuff still filled in, without any error message.

I’ve tried looking at each and every field and I cannot find anything wrong… I’ve also tried multiple web browsers but that doesn’t seem to change anything at all…

This is the “Submit a New Add-on” > “Describe Add-on” page. Accessible after I’ve uploaded my extension.

Any suggestions or help would be much appreciated!

(if it matters, I already have another extension published, and haven’t had any problems with that one)

(Jorge) #2

We’ve seen similar bugs in the past, where the extension metadata is localized and some of those translations are incomplete or don’t meet the size requirements. Can you check on that? If that doesn’t work, please file an issue here: https://github.com/mozilla/addons/issues/new

(Linus) #3

I don’t think that that is the problem since it’s an entirely new extension. Unless I’m missing something, I cannot even access that data.

There is only a “Resume” and “Delete” option, and “Resume” takes me to the page where I cannot submit :thinking:

I’ll open an issue on the addons repo, thanks for the quick response!

(Linus) #4

@jorgev I’m not getting any response on my issue, you don’t happen to know of someone I can ping on it? :relaxed: Would love to get my extension out

(Jorge) #5

What’s the issue you opened (if it’s still open)?

(Linus) #6

Thanks!