[CLOSED] Can't prevent model download


Trying to use basic TTS like:

   $ tts --text "Good morning world" \
       --model_name tts_models/en/ljspeech/tacotron2-DCA \
       --config_path Acoustic/tts_models--en--ljspeech--tacotron2-DCA/config.json \
       --model_path  Acoustic/tts_models--en--ljspeech--tacotron2-DCA/model_file.pth.tar \
       --vocoder_name vocoder_models/en/ljspeech/mulitband-melgan \
       --vocoder_path Vocoder/vocoder_models--en--ljspeech--mulitband-melgan/model_file.pth.tar \
       --vocoder_config_path Vocoder/vocoder_models--en--ljspeech--mulitband-melgan/config.json \
       --out_path /tmp/

It works fine - but although the models could be found at indicated locations I cannot prevent the download of models from some Google drive.

2021-02-26 10:50:21.535612: I tensorflow/stream_executor/platform/default/dso_loader.cc:48] Successfully opened dynamic library libcudart.so.10.1
> Downloading model to /home/someuser/.local/share/tts/tts_models--en--ljspeech--tacotron2-DCA

The corresponding config.json files are modified to point to the right stats_path.
Trying to setup this on multiple PCs and the download bit is very annoying.
Is there a way to prevent this download - am i missing something obvious here?

never mind;
after reading the source code turns out --model_name and --vocoder_name are not required - works fine when omitted

Not sure if you know but the downloaded models go into a location under a .TTS folder in your home directory, as described here:

So if you’re setting up on multiple machines you can copy the files to that location manually from the first machine and then you’ll see the --list_models show the available models correctly and you can use the name rather than having to remember a particular path. Of course the way you describe in your second post is also a perfectly valid approach, so it’s just a matter of preference here really.

1 Like