ConBee II support?

Okay
So i should remove the addon and try to make it work?

Im trying to use the Conbee II dongle with official Raspberry os from WebThings. When i enable the Zigbee Adapter i get this error in the logs:

  • 2019-05-16 10:31:27.016 INFO : Checking for add-on updates…*
  • 2019-05-16 10:31:27.503 INFO : Finished updating add-ons*
  • 2019-05-16 10:32:26.634 INFO : Loading add-on: zigbee-adapter*
  • 2019-05-16 10:32:27.311 INFO : zigbee: Opening database: /home/pi/.mozilla-iot/config/db.sqlite3*
  • 2019-05-16 10:32:27.352 INFO : zigbee: Loading add-on for zigbee-adapter from /home/pi/.mozilla-iot/addons/zigbee-adapter*
  • 2019-05-16 10:32:27.932 INFO : zigbee: DEBUG config = ‘’*
  • 2019-05-16 10:32:28.198 INFO : zigbee: Serial ports that were found:*
  • 2019-05-16 10:32:28.375 INFO : zigbee: Serial Device found @ /dev/ttyAMA0*
  • 2019-05-16 10:32:28.378 INFO : zigbee: Serial Device found @ /dev/ttyS0*
  • 2019-05-16 10:32:28.380 INFO : zigbee: USB Serial Device 1cf1:0030 Vendor: dresden elektronik ingenieurtechnik GmbH Serial: DE1964053 found @ /dev/ttyACM0*
  • 2019-05-16 10:32:28.383 ERROR : zigbee: Failed to load zigbee-adapter - No Zigbee dongle found*
  • 2019-05-16 10:32:28.796 INFO : Plugin: zigbee-adapter died, code = 100 NOT restarting…*

I see that the Dresden device is recognized but maybe not as a Zigbee dongle.
I also tried to update the firmware of the dongle but still no luck.
Anyone managed to get it working?

@dhylands I think we just need to allow this ID through for the serial prober.

Good to hear
I thought i was just for me the conbee II issue
How do i allow this to make it work?
I have tried to plug it into my windows 10 PC and i get accurate readings from my aqara sensors with the Phoscon sofware and the Conbee II.
//Per

Is that something i can do myself?

I’ve opened the same issue here Zigbee: Failed to load zigbee-adapter - No Zigbee dongle found

How I can allow Conbee II Id to the serial prober ?

The ConBee II should now be suppored by version 0.7.7 of the zigbee adapter.

Just released version 0.7.8 which should work better with the ConBee II. It now resets the watchdog timer which was causing the dongle to become disconnected about an hour after being plugged in.

1 Like

hi @dhylands IMO putting a note on the ‘supported devices’ list is a great idea. I also bought some Xiaomi Zigbee sensors, which I wouldn’t have done had there been a warning.

They are available for amazing prices on aliexpress so I’d assume many n00bs like myself have or will fall into this trap, only to have them be flakey.

1 Like

Thanks for the suggestion. I updated the supported hardware page.

@dhylands, might be helpful to add this dongle (ConBee II) to the adapters list as well. Links:

I confirm like many others, there is a connection lost problem with the Xiaomi Aqara WSDCGQ11LM (temperature/humidity). They work only for few hours and need to be resync manually.

also with 0.8.1 conbee II loeses connection to Ikea blubs and plugs. :frowning:
With the phoscon Pi Image the connection is stable.

Be sure to update to the latest zigbee adapter.

I’m using zigbee adapter 7.14 on a new raspberry PI with a ConBee II dongle. This system won’t identify any of the new Cree bulbs I am trying to connect. I have another PI with an XStick2 ZB and that one identifies the bulbs just fine.

I’m trying to figure out if I have a defective dongle or if there are still issues using the ConBee. What can I check next?

Ignoring the date/time of the log entries, they’re actually for yesterday and today (November 12 and 13), here are the log entries related:

2019-08-14 23:17:40.340 ERROR : zigbee: Failed to load zigbee-adapter - Error: Port /dev/ttyACM0 looks like it might be a/an deConz dongle, but it couldn’t be opened. SerialProber: timeout: deConz dongle not detected on /dev/ttyACM0
2019-08-14 23:17:40.342 ERROR : zigbee: at Function.probeAll (/home/pi/.mozilla-iot/addons/zigbee-adapter/node_modules/serial-prober/serial-prober.js:157:19)
2019-08-14 23:17:40.344 ERROR : zigbee: at
2019-08-14 23:17:40.348 INFO : zigbee: Unhandled Rejection
2019-08-14 23:17:40.350 ERROR : zigbee: { Error: Canceled
2019-08-14 23:17:40.351 ERROR : zigbee: at Poller.emitCanceled (/home/pi/.mozilla-iot/addons/zigbee-adapter/node_modules/@serialport/bindings/lib/poller.js:101:17)
2019-08-14 23:17:40.353 ERROR : zigbee: at Poller.stop (/home/pi/.mozilla-iot/addons/zigbee-adapter/node_modules/@serialport/bindings/lib/poller.js:91:10)
2019-08-14 23:17:40.354 ERROR : zigbee: at close.then (/home/pi/.mozilla-iot/addons/zigbee-adapter/node_modules/@serialport/bindings/lib/linux.js:48:19)
2019-08-14 23:17:40.356 ERROR : zigbee: at canceled: true }

@dale1 Do you maybe have permissions issues with your dongle? Are you running are gateway image or something you built yourself?

I’m using the latest downloaded PI image from Mozilla, 0.9.2. I followed the same process that I used when I created my first gateway except that in the first case I used the XStick instead of the ConBee: I downloaded the latest image, burned it to SDRam using Etcher, ensured that the USB gateway was plugged in before first power-on of the PI, and powered up.

The ConBee I ordered, just coincidentally, is the same one IGx89 posted above about from Amazon on June 12 in this thread.

Well, here’s a strange update. Short story: it’s working now.

Long story, I had tried rebooting multiple times, I had powered off and powered back on, all to no avail. I went to bed Wednesday night with it not working, getting the error shown in the log snippet above.

When I got home from work Thursday I thought I’d try again. The first thing I did was set the clock so I could get the real date and time in the log and then I restarted again, no power off - just shutdown -r now. When it came back up, I checked the log again and there were some errors but it appeared the ConBee was going to work.

I’m using this gateway for a second location and also to screen capture/document my Python code for an article so I can show it from scratch.

I tried to add sample light I was using for my example and it was found right away and added and controlled successfully!

Overnight, I got several watchdog messages so dhylands’ watchdog code is working and all seems good there.

There are still several odd errors in the log related to Confirm Status: 233: unknown addr: e20db9fffe09d2de 44f3. I’ll research those in the code and documentation before posting another thread on that process. When I turned on my lamp this morning (I shut it off with the physical switch last night), the gateway page synced itself with the status, showing the light on, within about 2 seconds. I think that’s related to the Confirm Status error messages. It was certainly desirable behavior so I’m not sure it’s actually an error.

Anyway, my ConBee appears to be working.

My Conbee II is very intermittent. I will reboot my RPi3, it tells me Zigbee device not found. I restart the gateway, same. lsusb shows me it is there. Reboot again, it finally shows up. Weird! Why?