Do you have to use a raspberry pi?

I installed raspberry pi desk top on an old computer to try to set up the gateway I also tried Ubuntu (to heavy for the old pc), but I had the same problem both times. It says it can’t find a package to install. I tried updating and upgrading apt but it doesn’t work. So can I not use a pc running Linux distros or I’m a just doing something wrong?

WebThings runs nicely using the Docker image. My test system runs on Ubuntu Buster 20.04, and my main system runs on a RPI 2B+ Raspian. Make sure you using WebThings 1.0 (, not the legacy Mozilla image which no longer works.

If you can’t upgrade your system using apt then you have other problems which you should resolve first. It’s does not take much time to re-install Ubuntu or Raspian if you’ve messed around too much…

I’m using 1.0. I’ve upgraded the system with apt but it still can’t find the package to install. But I’m not using a raspberry pi could that be the issue?

.deb and .rpm packages are available on the releases page:

I tried that. It’s the first thing I did. Raspberry pi os, Ubuntu, and Linux mint, none could install it

OK so the closest I’ve come is sudo apt deb. It wants to install it but it says it’s missing dependencies but when I try to update them it says it can’t locate package python pip. Any suggestions

Just tried docker to and it won’t work there either. Mind you I have no idea what I’m doing and am just going by the documentation.

Did you check the gateway log file for errors?

Here is the Docker start command I use.

  • ttyACM0 is the device name for the Z-Wave USB dongle. You may need to pass in another device.
  • /mnt/EdbergFS/mozilla-iot is the persistent storage location/folder where data, addons, and logs are stored

docker rm webthingsio-gateway

docker run -d --restart always --net=host
-e TZ=America/Chicago
–device /dev/ttyACM0:/dev/ttyACM0
–log-opt max-size=1m
–log-opt max-file=5
-v /etc/timezone:/etc/timezone:ro
-v /mnt/EdbergFS/mozilla-iot:/home/node/.mozilla-iot
–name webthingsio-gateway webthingsio/gateway

Thanks I’ll try that. I have no idea how to check the gateway log file for errors, what an error would look like or how to fix it lol. I’ll try you start command. I appreciate the help