Error training: prefix ProgressBar

Hi . I tried to train my own model but when I executed the training script the error was:

(DeepSpeech) C:\Users\Voice-trainner\STT\DeepSpeech>python --train_files train.csv --dev_files dev.csv --test_files test.csv --audio_sample_rate 8000 --export_dir Models --export_tflite True
I Could not find best validating checkpoint.
I Could not find most recent checkpoint.
I Initializing all variables.
I STARTING Optimization
I Training epoch 0…
prefix is Epoch 0 | Training
widgets is [’ | ', <progressbar.widgets.Timer object at 0x0000021F7F9F70C8>, ’ | Steps: ', <progressbar.widgets.Counter object at 0x0000021F7F9F7148>, ’ | ', <training.deepspeech_training.train.train..run_set..LossWidget object at 0x0000021F7F9F4AB0>]
suffix is None
Traceback (most recent call last):
File “”, line 12, in
File “C:\Users\Voice-trainner\STT\DeepSpeech\training\deepspeech_training\”, line 982, in run_script
File “C:\Users\Voice-trainner\anaconda3\envs\DeepSpeech\lib\site-packages\absl\”, line 303, in run
_run_main(main, args)
File “C:\Users\Voice-trainner\anaconda3\envs\DeepSpeech\lib\site-packages\absl\”, line 251, in _run_main
File “C:\Users\Voice-trainner\STT\DeepSpeech\training\deepspeech_training\”, line 954, in main
File “C:\Users\Voice-trainner\STT\DeepSpeech\training\deepspeech_training\”, line 607, in train
train_loss, _ = run_set(‘train’, epoch, train_init_op)
File “C:\Users\Voice-trainner\STT\DeepSpeech\training\deepspeech_training\”, line 562, in run_set
pbar = create_progressbar(prefix=prefix, widgets=widgets, suffix=suffix).start()
File “C:\Users\Voice-trainner\STT\DeepSpeech\training\deepspeech_training\util\”, line 45, in create_progressbar
return progressbar.ProgressBar(*args, **kwargs)
TypeError: init() got an unexpected keyword argument 'prefix’

I installed progressbar 2.5 package.

Follow the docs, don’t install random packages.

Training is not supported on Windows.

Which OS do you recommend me to execute training? I can choose between Ubuntu 18.04 or Centos7. Thanks a lot

Ubuntu 18.04 is something i know will work CentOS should as well, but im no user of it.

HI. I am trying to train on Ubuntu 18.04, Python 3.6.9, step by step as you mention on

When I execute:

pip3 install --upgrade -e .

I got the following message:

tensorflow 1.15.4 requires numpy<1.19.0,>=1.16.0, but you’ll have numpy 1.19.5 which is incompatible

Thanks a lot (this is one of the same errors that I got when I tried on Windows a couple of days ago)

Sorry, i dont know why, and i cant help.

Ok It does not matter. But I have a last question. Now when I execute

python3 --helpfull

I got:

Illegal instruction (core dumped)

As mentionned next to my name, I don’t work on DeepSpeech anymore.
I have no idea what is failing in your case, and SIGILL without any context nor with a stacktrace in completely unactionable.