FireFox 57 Quantum messed-up dev tools


Firefox just updated itself to v.57.0 Quantum on my machine and my development came to a halt. I am no longer able to see parameters of data submitted via POST and corresponding response. Everything worked great in the previous version. Yes, the browser seems faster, but as dev I have to go back to Chrome…

(Harald Kirschner) #2

Could you provide more details on this, sounds like you are running into a bug as the feature exists.

Both Console (with Network enabled) and Network panel show the Params panel, showing POST details. Here an example how it looks:

Edit: This might be related, are you looking at Console? XHR request parametrs

(Dominik Leiner) #3

I encounter a similar problem since the Quantum update. As soon as the developer console opens, the website displays additional content at the end (it disappears when the developer tools are closed), and an error message is displayed (“the debugger was stopped”).


As this problem occurs on my local development server, I am currently unable to give a test URL to reproduce the problem.

Edit 1

Here’s a screenshot displaying the rror more in detail.


Edit 2

Here’s a demo URL:

Load this normally, and the slider will work fine.

Open the developer tools, and reload the page. Neither the dev tools will work any more, nor the sliders, nor the F5 button.

Using Firefox 57.0 (64 bit) in German on Win10. Unfortunately, I am unable to install the nightly built on this PC. But maybe the demo URL allows you such a test.


@Dominik Despite looking at it for a minute or so

I cannot see what you describe in your screenshot. Could you maybe annotate it with a red arrow or something? (also this seems to be something different than what @santa describes above).

I would be curious if your problem can be reproduced with Firefox Nightly (if not, then it would be a bug probably that has been fixed in the meantime). Or Developer Edition (which is like beta). If it still occurs then Steps to reproduce would be good.

(Mike Ratcliffe) #5

@Dominik If you mean that the developer tools panel has a console at the bottom then pressing will hide / show it.

(Dominik Leiner) #6

@MikeRatcliffe No, I’m regularly working with the dev tools - it is actually content added to the page content (also visible in the inspector/DOM explorer), some <fieldset>. I guess this is added temporarily, and then the script crashes, leaving the content in the page.

I’m quite sure that this content is not part of the original page, as I have written that including most of the scripts running on the page.

(Dominik Leiner) #8

@nachtigall The page does not use or load jQuery itself. Therefore the error on the right does probably stem from the dev tools (see new screenshot). I was also able to reproduce the problem on a different web page, and posted a test URL above.

(Mike Ratcliffe) #9

@Dominik Your issue is caused by an extension. We can see this because the URL starts with moz-extension://e30437be-b749-4df7-ba37-e3b49116a168

Can you go to about:debugging, search for e30437be-b749-4df7-ba37-e3b49116a168 and let us know which extension is causing the problem? Disabling this extension will fix your problem.

(Dominik Leiner) #10

Alright - the issue was caused by the extension (Adobe Acrobat). After disabling the add-on, the developer tools are working.

Still, I would consider it an important improvement for the dev tools not to be killed/stopped by a third-party extension.

(Mike Ratcliffe) #11

@Dominik I have opened an issue for you at

(Julian Descottes) #12

It seems like @Dominik currently has its debugger set to “Pause on all exceptions” (according to the color of the associated icon on the screenshot below)


The mentioned extension happens to throw an exception on the load of the page. You could click again on this icon to no longer break on exceptions. So the enhancement here would be to avoid breaking on webextensions code maybe?

(Jason Laster) #13

Hi! I just tried again in Firefox Nightly and it seemed to work.

Note, the pause on all exceptions was moved to a + in the Breakpoints pane